summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-06 15:25:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-06 15:27:29 -0500
commit189c2a1f33b86bbdab28812f0960ad0372208d4c (patch)
treef4955c60a33992e6c211a33b96ad27879adcce32 /app-crypt
parentapp-crypt/acme: 1.4.0 bump (diff)
downloadgentoo-189c2a1f33b86bbdab28812f0960ad0372208d4c.tar.gz
gentoo-189c2a1f33b86bbdab28812f0960ad0372208d4c.tar.bz2
gentoo-189c2a1f33b86bbdab28812f0960ad0372208d4c.zip
app-crypt/certbot: 1.4.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-1.4.0.ebuild48
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild1
3 files changed, 49 insertions, 1 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index c6644fcb5db8..24824d6ddbee 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1 +1,2 @@
DIST certbot-1.3.0.tar.gz 1362945 BLAKE2B bb36a7737275332f018d7f2283286e07e041892cc366f79e68df9eee7e57ca2186d36895d1923b032068a365878d09e49e17c1399a7418dbd8607c9a7efc1c26 SHA512 4205cdd1f3ddf500b9b952744db234636c086a856df80acd2d776305f4501eed07995e453e5c9b2c711fb0d1f1987d2bb8baaa13fccce8e000a38f486cfdc5d3
+DIST certbot-1.4.0.tar.gz 1381435 BLAKE2B 57d70a12ee38e1ba96f4c8c594c1940403e33d4cdf5111472a9c0c7d41061b2201792c38d9bb4ec516358f5592d2f689eeab31e1e686a534418b20eba2df4b4b SHA512 8926f724c47c0249e2e420cd8944f0b106682efaa2d9b211491ea4524fe4e64bb3ff4f21fd756996049d781a68294ab8307bd077b6d96fa00e09cbbdf4e59261
diff --git a/app-crypt/certbot/certbot-1.4.0.ebuild b/app-crypt/certbot/certbot-1.4.0.ebuild
new file mode 100644
index 000000000000..182f2b91d51b
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+S=${WORKDIR}/${P}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=app-crypt/acme-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # required as deps of deps can trigger this too...
+ echo ' ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
+ distutils-r1_python_prepare_all
+}
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 5bbead32041e..182f2b91d51b 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -32,7 +32,6 @@ RDEPEND="
>=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
>=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
>=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]