summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatija Skala <mskala@gmx.com>2019-07-12 18:25:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-18 09:52:01 +0200
commit301a958e477b016e486fbbd22a3ee5ace07941fa (patch)
treea8d0e22b715c787449328d8a412d7ed459368a8d /app-editors/nano/nano-3.2.ebuild
parentdb.eclass: de-uglyfied eclass a bit (diff)
downloadgentoo-301a958e477b016e486fbbd22a3ee5ace07941fa.tar.gz
gentoo-301a958e477b016e486fbbd22a3ee5ace07941fa.tar.bz2
gentoo-301a958e477b016e486fbbd22a3ee5ace07941fa.zip
app-editors/nano: add support for /usr merge
Signed-off-by: Matija Skala <mskala@gmx.com> Closes: https://github.com/gentoo/gentoo/pull/12432 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-editors/nano/nano-3.2.ebuild')
-rw-r--r--app-editors/nano/nano-3.2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-editors/nano/nano-3.2.ebuild b/app-editors/nano/nano-3.2.ebuild
index ef6555432c21..9c28db49f39f 100644
--- a/app-editors/nano/nano-3.2.ebuild
+++ b/app-editors/nano/nano-3.2.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+IUSE="debug justify +magic minimal ncurses nls slang +spell +split-usr static unicode"
LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
sys-libs/ncurses:0=[static-libs(+)]
@@ -79,5 +79,5 @@ src_install() {
"${ED%/}"/etc/nanorc || die
fi
- dosym ../../bin/nano /usr/bin/nano
+ use split-usr && dosym ../../bin/nano /usr/bin/nano
}