summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/fff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/fff')
-rw-r--r--app-emacs/fff/Manifest1
-rw-r--r--app-emacs/fff/fff-20050517.ebuild19
-rw-r--r--app-emacs/fff/files/50fff-gentoo.el17
-rw-r--r--app-emacs/fff/metadata.xml13
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/fff/Manifest b/app-emacs/fff/Manifest
new file mode 100644
index 000000000000..8e3f3733bab1
--- /dev/null
+++ b/app-emacs/fff/Manifest
@@ -0,0 +1 @@
+DIST fff-20050517.tar.bz2 13774 SHA256 c6333255ebe50d481e4b7d7472a445b1bcd268622771bcd640a7201f82b07ee0 SHA512 829a833a25378d868db0dad04d062c397336aa98167fd5706a9c75a7ec4c60a49bc77b5dfa9ed9f48565d09ae2817fafeffeb7546b5e5bbfcd13c78fcdfc9939 WHIRLPOOL 05f6c9ddedadc7025006ab520e70531847f636d5be93d773a61a6a1a9819e2141d5395e647ae7aae80573ed22ce60bb53b16a657581dc530b898308c7e7ac62f
diff --git a/app-emacs/fff/fff-20050517.ebuild b/app-emacs/fff/fff-20050517.ebuild
new file mode 100644
index 000000000000..91ea6aef3897
--- /dev/null
+++ b/app-emacs/fff/fff-20050517.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Fast file finder for Emacs"
+HOMEPAGE="http://www.splode.com/~friedman/software/emacs-lisp/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sys-apps/mlocate"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/fff/files/50fff-gentoo.el b/app-emacs/fff/files/50fff-gentoo.el
new file mode 100644
index 000000000000..84df8bdd9e8b
--- /dev/null
+++ b/app-emacs/fff/files/50fff-gentoo.el
@@ -0,0 +1,17 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'fff-find-file-in-envvar-path "fff" nil t)
+(autoload 'fff-insert-file-in-envvar-path "fff" nil t)
+(autoload 'fff-find-file-in-exec-path "fff" nil t)
+(autoload 'fff-insert-file-in-exec-path "fff" nil t)
+(autoload 'fff-find-file-in-path "fff" nil t)
+(autoload 'fff-insert-file-in-path "fff" nil t)
+(autoload 'fff-find-file-in-locate-db "fff" nil t)
+(autoload 'fff-insert-file-in-locate-db "fff" nil t)
+(autoload 'fff-install-map "fff" nil t)
+(autoload 'fff-find-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-insert-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-locate-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-find-loaded-elisp-function-or-variable "fff-elisp" nil t)
+(autoload 'fff-elisp-install-map "fff-elisp" nil t)
+(autoload 'fff-find-rfc "fff-rfc" nil t)
+(autoload 'fff-rfc-install-map "fff-rfc" nil t)
diff --git a/app-emacs/fff/metadata.xml b/app-emacs/fff/metadata.xml
new file mode 100644
index 000000000000..d66f0dd32b1e
--- /dev/null
+++ b/app-emacs/fff/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ This package provides several shortcut commands for visiting or
+ inserting files without having to specify them by their complete name.
+ For example, you can visit programs in your exec-path (some of which
+ may be humanly-readable shell scripts or config files), or anything
+ else which is quickly locatable via a prebuilt database or path list.
+ Completion is also available for many commands.
+</longdescription>
+</pkgmetadata>