summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/fff')
-rw-r--r--app-emacs/fff/Manifest1
-rw-r--r--app-emacs/fff/fff-20050517.ebuild19
-rw-r--r--app-emacs/fff/files/50fff-gentoo.el17
-rw-r--r--app-emacs/fff/metadata.xml13
4 files changed, 50 insertions, 0 deletions
diff --git a/app-emacs/fff/Manifest b/app-emacs/fff/Manifest
new file mode 100644
index 000000000000..8e3f3733bab1
--- /dev/null
+++ b/app-emacs/fff/Manifest
@@ -0,0 +1 @@
+DIST fff-20050517.tar.bz2 13774 SHA256 c6333255ebe50d481e4b7d7472a445b1bcd268622771bcd640a7201f82b07ee0 SHA512 829a833a25378d868db0dad04d062c397336aa98167fd5706a9c75a7ec4c60a49bc77b5dfa9ed9f48565d09ae2817fafeffeb7546b5e5bbfcd13c78fcdfc9939 WHIRLPOOL 05f6c9ddedadc7025006ab520e70531847f636d5be93d773a61a6a1a9819e2141d5395e647ae7aae80573ed22ce60bb53b16a657581dc530b898308c7e7ac62f
diff --git a/app-emacs/fff/fff-20050517.ebuild b/app-emacs/fff/fff-20050517.ebuild
new file mode 100644
index 000000000000..91ea6aef3897
--- /dev/null
+++ b/app-emacs/fff/fff-20050517.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Fast file finder for Emacs"
+HOMEPAGE="http://www.splode.com/~friedman/software/emacs-lisp/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sys-apps/mlocate"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/fff/files/50fff-gentoo.el b/app-emacs/fff/files/50fff-gentoo.el
new file mode 100644
index 000000000000..84df8bdd9e8b
--- /dev/null
+++ b/app-emacs/fff/files/50fff-gentoo.el
@@ -0,0 +1,17 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'fff-find-file-in-envvar-path "fff" nil t)
+(autoload 'fff-insert-file-in-envvar-path "fff" nil t)
+(autoload 'fff-find-file-in-exec-path "fff" nil t)
+(autoload 'fff-insert-file-in-exec-path "fff" nil t)
+(autoload 'fff-find-file-in-path "fff" nil t)
+(autoload 'fff-insert-file-in-path "fff" nil t)
+(autoload 'fff-find-file-in-locate-db "fff" nil t)
+(autoload 'fff-insert-file-in-locate-db "fff" nil t)
+(autoload 'fff-install-map "fff" nil t)
+(autoload 'fff-find-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-insert-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-locate-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-find-loaded-elisp-function-or-variable "fff-elisp" nil t)
+(autoload 'fff-elisp-install-map "fff-elisp" nil t)
+(autoload 'fff-find-rfc "fff-rfc" nil t)
+(autoload 'fff-rfc-install-map "fff-rfc" nil t)
diff --git a/app-emacs/fff/metadata.xml b/app-emacs/fff/metadata.xml
new file mode 100644
index 000000000000..d66f0dd32b1e
--- /dev/null
+++ b/app-emacs/fff/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ This package provides several shortcut commands for visiting or
+ inserting files without having to specify them by their complete name.
+ For example, you can visit programs in your exec-path (some of which
+ may be humanly-readable shell scripts or config files), or anything
+ else which is quickly locatable via a prebuilt database or path list.
+ Completion is also available for many commands.
+</longdescription>
+</pkgmetadata>