summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2016-09-04 15:28:43 +0000
committerErik Mackdanz <stasibear@gentoo.org>2016-09-04 15:29:40 +0000
commit7ff4458b663f7af03854c75f020e4fb60b68ab09 (patch)
tree6aec303e8b270fbbef7379a9ff79a526c16e353c /app-emulation/lxc/files
parentdev-ruby/rack: readd Prefix keywords, bug #587756 (diff)
downloadgentoo-7ff4458b663f7af03854c75f020e4fb60b68ab09.tar.gz
gentoo-7ff4458b663f7af03854c75f020e4fb60b68ab09.tar.bz2
gentoo-7ff4458b663f7af03854c75f020e4fb60b68ab09.zip
app-emulation/lxc: bump to 2.0.4
EAPI=6. Also add a condition around a removed kernel config option. Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/lxc/files')
-rw-r--r--app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch31
-rw-r--r--app-emulation/lxc/files/lxc-2.0.4-omit-sysconfig.patch5
2 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch b/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch
new file mode 100644
index 000000000000..6feb4c2bb01c
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch
@@ -0,0 +1,31 @@
+--- /config/bash/Makefile.am.orig 2016-05-18 20:40:42.238487678 +0000
++++ /config/bash/Makefile.am 2016-05-18 20:43:02.163497779 +0000
+@@ -2,12 +2,12 @@
+
+ if ENABLE_BASH
+ install-bash:
+- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
+- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
++ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions/
++ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
+
+ uninstall-bash:
+- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
+- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
++ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
++ rmdir $(DESTDIR)$(datarootdir)/bash-completion/completions/ || :
+
+ install-data-local: install-bash
+ uninstall-local: uninstall-bash
+--- /config/bash/lxc.in.orig 2016-05-18 20:40:51.079488316 +0000
++++ /config/bash/lxc.in 2016-05-18 20:45:03.506506538 +0000
+@@ -1,4 +1,3 @@
+-_have lxc-start && {
+ _lxc_names() {
+ COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
+ }
+@@ -100,4 +99,3 @@
+
+ complete -o default -F _lxc_generic_o lxc-copy
+ complete -o default -F _lxc_generic_o lxc-start-ephemeral
+-}
diff --git a/app-emulation/lxc/files/lxc-2.0.4-omit-sysconfig.patch b/app-emulation/lxc/files/lxc-2.0.4-omit-sysconfig.patch
new file mode 100644
index 000000000000..3ec81356499e
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-2.0.4-omit-sysconfig.patch
@@ -0,0 +1,5 @@
+--- /config/Makefile.am.orig 2016-05-19 02:56:11.891113982 +0000
++++ /config/Makefile.am 2016-05-19 02:56:32.596115476 +0000
+@@ -1 +1 @@
+-SUBDIRS = apparmor bash etc init selinux templates yum sysconfig
++SUBDIRS = apparmor bash etc init selinux templates yum