summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-05-28 11:57:06 -0400
committerNick Sarnie <sarnex@gentoo.org>2018-05-28 11:57:06 -0400
commit47c706f3f2bdf23a4d4de728ea804613dcef0fe2 (patch)
treed40524ba5acfa2a4ad3d0bff446a43f91f6e4c76 /app-emulation/vkd3d/vkd3d-9999.ebuild
parentprofiles/arch/amd64: Unmask app-emulation/wine-*[vkd3d] on amd64 (diff)
downloadgentoo-47c706f3f2bdf23a4d4de728ea804613dcef0fe2.tar.gz
gentoo-47c706f3f2bdf23a4d4de728ea804613dcef0fe2.tar.bz2
gentoo-47c706f3f2bdf23a4d4de728ea804613dcef0fe2.zip
app-emulation/vkd3d: Sync with ::wine
Initial version of vkd3d Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation/vkd3d/vkd3d-9999.ebuild')
-rw-r--r--app-emulation/vkd3d/vkd3d-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/vkd3d-9999.ebuild b/app-emulation/vkd3d/vkd3d-9999.ebuild
new file mode 100644
index 000000000000..88db9b6937ff
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://dev.gentoo.org/~sarnex/distfiles/vkd3d-${PV}.tar.xz"
+ S="${WORKDIR}/${PN}"
+fi
+
+IUSE="spirv-tools"
+RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
+ x11-libs/xcb-util-keysyms:=[${MULTILIB_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_with spirv-tools)
+ )
+
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}