summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-04-09 14:01:59 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-04-09 14:15:28 -0400
commit72f76cae15de74cb99a604303de297fb5412d68f (patch)
treeb7441a26888711cf5ae8447f7a91c2a0b39464fb /app-emulation
parentapp-emulation/wine: Fix logic evaluation order (diff)
downloadgentoo-72f76cae15de74cb99a604303de297fb5412d68f.tar.gz
gentoo-72f76cae15de74cb99a604303de297fb5412d68f.tar.bz2
gentoo-72f76cae15de74cb99a604303de297fb5412d68f.zip
app-emulation/wine: Change GCC 5.3 warning, per mgorny request.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/wine-1.8.1.ebuild4
-rw-r--r--app-emulation/wine/wine-1.8.ebuild13
-rw-r--r--app-emulation/wine/wine-1.9.4.ebuild9
-rw-r--r--app-emulation/wine/wine-1.9.5.ebuild4
-rw-r--r--app-emulation/wine/wine-1.9.6.ebuild4
-rw-r--r--app-emulation/wine/wine-9999.ebuild4
6 files changed, 25 insertions, 13 deletions
diff --git a/app-emulation/wine/wine-1.8.1.ebuild b/app-emulation/wine/wine-1.8.1.ebuild
index 1d2d4c83e84f..882344891c63 100644
--- a/app-emulation/wine/wine-1.8.1.ebuild
+++ b/app-emulation/wine/wine-1.8.1.ebuild
@@ -182,8 +182,8 @@ wine_build_environment_check() {
# Compile in subshell to prevent "Aborted" message
if ! ( $(tc-getCC) -O2 -mincoming-stack-boundary=3 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || false ) >/dev/null 2>&1; then
eerror "Wine cannot be built with this version of gcc-5.3"
- eerror "due to compiler bugs; please re-emerge the latest gcc-5.3.x ebuild,"
- eerror "or use gcc-config to select a different compiler version."
+ eerror "due to compiler bugs; please use gcc-config to select a"
+ eerror "different compiler version."
eerror "See https://bugs.gentoo.org/574044"
eerror
return 1
diff --git a/app-emulation/wine/wine-1.8.ebuild b/app-emulation/wine/wine-1.8.ebuild
index 4c1b6f446af0..d28d9bac7576 100644
--- a/app-emulation/wine/wine-1.8.ebuild
+++ b/app-emulation/wine/wine-1.8.ebuild
@@ -177,6 +177,19 @@ wine_build_environment_check() {
return 1
fi
fi
+ # bug #574044
+ if use abi_x86_64 && [[ $(gcc-major-version) = 5 && $(gcc-minor-version) = 3 ]]; then
+ einfo "Checking for gcc-5-3 stack realignment compiler bug ..."
+ # Compile in subshell to prevent "Aborted" message
+ if ! ( $(tc-getCC) -O2 -mincoming-stack-boundary=3 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || false ) >/dev/null 2>&1; then
+ eerror "Wine cannot be built with this version of gcc-5.3"
+ eerror "due to compiler bugs; please use gcc-config to select a"
+ eerror "different compiler version."
+ eerror "See https://bugs.gentoo.org/574044"
+ eerror
+ return 1
+ fi
+ fi
if use abi_x86_64 && [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]]; then
eerror "You need gcc-4.4+ to build 64-bit wine"
diff --git a/app-emulation/wine/wine-1.9.4.ebuild b/app-emulation/wine/wine-1.9.4.ebuild
index e47fe62c7432..70ad7280bfa1 100644
--- a/app-emulation/wine/wine-1.9.4.ebuild
+++ b/app-emulation/wine/wine-1.9.4.ebuild
@@ -177,12 +177,11 @@ wine_build_environment_check() {
# bug #574044
if use abi_x86_64 && [[ $(gcc-major-version) = 5 && $(gcc-minor-version) = 3 ]]; then
einfo "Checking for gcc-5-3 stack realignment compiler bug ..."
- $(tc-getCC) -O2 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || die
- # Run in subshell to prevent "Aborted" message
- if ! ( "${T}"/69140 || false ) >/dev/null 2>&1; then
+ # Compile in subshell to prevent "Aborted" message
+ if ! ( $(tc-getCC) -O2 -mincoming-stack-boundary=3 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || false ) >/dev/null 2>&1; then
eerror "Wine cannot be built with this version of gcc-5.3"
- eerror "due to compiler bugs; please re-emerge the latest gcc-5.3.x ebuild,"
- eerror "or use gcc-config to select a different compiler version."
+ eerror "due to compiler bugs; please use gcc-config to select a"
+ eerror "different compiler version."
eerror "See https://bugs.gentoo.org/574044"
eerror
return 1
diff --git a/app-emulation/wine/wine-1.9.5.ebuild b/app-emulation/wine/wine-1.9.5.ebuild
index 509dbfe69bf8..6f64997b75fc 100644
--- a/app-emulation/wine/wine-1.9.5.ebuild
+++ b/app-emulation/wine/wine-1.9.5.ebuild
@@ -179,8 +179,8 @@ wine_build_environment_check() {
# Compile in subshell to prevent "Aborted" message
if ! ( $(tc-getCC) -O2 -mincoming-stack-boundary=3 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || false ) >/dev/null 2>&1; then
eerror "Wine cannot be built with this version of gcc-5.3"
- eerror "due to compiler bugs; please re-emerge the latest gcc-5.3.x ebuild,"
- eerror "or use gcc-config to select a different compiler version."
+ eerror "due to compiler bugs; please use gcc-config to select a"
+ eerror "different compiler version."
eerror "See https://bugs.gentoo.org/574044"
eerror
return 1
diff --git a/app-emulation/wine/wine-1.9.6.ebuild b/app-emulation/wine/wine-1.9.6.ebuild
index e735b28385d7..8a68ba0c01b5 100644
--- a/app-emulation/wine/wine-1.9.6.ebuild
+++ b/app-emulation/wine/wine-1.9.6.ebuild
@@ -180,8 +180,8 @@ wine_build_environment_check() {
# Compile in subshell to prevent "Aborted" message
if ! ( $(tc-getCC) -O2 -mincoming-stack-boundary=3 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || false ) >/dev/null 2>&1; then
eerror "Wine cannot be built with this version of gcc-5.3"
- eerror "due to compiler bugs; please re-emerge the latest gcc-5.3.x ebuild,"
- eerror "or use gcc-config to select a different compiler version."
+ eerror "due to compiler bugs; please use gcc-config to select a"
+ eerror "different compiler version."
eerror "See https://bugs.gentoo.org/574044"
eerror
return 1
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index e735b28385d7..8a68ba0c01b5 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -180,8 +180,8 @@ wine_build_environment_check() {
# Compile in subshell to prevent "Aborted" message
if ! ( $(tc-getCC) -O2 -mincoming-stack-boundary=3 "${FILESDIR}"/pr69140.c -o "${T}"/pr69140 || false ) >/dev/null 2>&1; then
eerror "Wine cannot be built with this version of gcc-5.3"
- eerror "due to compiler bugs; please re-emerge the latest gcc-5.3.x ebuild,"
- eerror "or use gcc-config to select a different compiler version."
+ eerror "due to compiler bugs; please use gcc-config to select a"
+ eerror "different compiler version."
eerror "See https://bugs.gentoo.org/574044"
eerror
return 1