summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/crunch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/crunch')
-rw-r--r--app-misc/crunch/Manifest3
-rw-r--r--app-misc/crunch/crunch-3.4.ebuild28
-rw-r--r--app-misc/crunch/crunch-3.5.ebuild30
-rw-r--r--app-misc/crunch/crunch-3.6.ebuild30
-rw-r--r--app-misc/crunch/files/crunch-3.4-gentoo.patch34
-rw-r--r--app-misc/crunch/metadata.xml11
6 files changed, 136 insertions, 0 deletions
diff --git a/app-misc/crunch/Manifest b/app-misc/crunch/Manifest
new file mode 100644
index 000000000000..69042a6e318f
--- /dev/null
+++ b/app-misc/crunch/Manifest
@@ -0,0 +1,3 @@
+DIST crunch-3.4.tgz 38388 SHA256 cd3b46409a1d8a3adeac68b1b618b2773c7dd4085d61e37f9d02a2060f261922 SHA512 b433c4cb0eb42ce4e76bb8c77d26f3738bd73f925d69c1e4220ac186daf6b8afe20665dfb87e0e869b0a3bb91fb76f1b341a438cd219afa0629ca961c13a71a8 WHIRLPOOL b089c2306f7a4fbf5412f7667bdb521b24748f4786c2b80ae0dea78efb3e1144b53507a66a242842b73499e01ced3f7ff867b562eed6a20ee1bced2731e9d39d
+DIST crunch-3.5.tgz 38459 SHA256 471195d9503f3420ffe80da00c1bc2e392e9bf39918ddda3cf0eaf5ef5627fda SHA512 70280e290fae392a1bd2c07f0235945438f81bccad055fe69d2ac94fedfd5f95fc22ba528be7671bb68fd33c824171fd03589d72bd089e806ff22d88c6e6e087 WHIRLPOOL 7a3b78cdb22362ca6d2c5d1b0898a3131726bc0b505aff20f6314c5ae5e17108998d123552797e3d834301d823a70eff56eb39264f2c810c0741ab2178bf3743
+DIST crunch-3.6.tgz 38635 SHA256 6a8f6c3c7410cc1930e6854d1dadc6691bfef138760509b33722ff2de133fe55 SHA512 85a2a12bb481988ab27a19602122abc29bb307de0af279132dcc0565dfc4ba44ab9f7ca15d876001f2e6dcf7be77ed50168cb066fc6a65bf06ec5cf9d798e81f WHIRLPOOL 79a27e8af6472f4ab5a604e42a25e80aa957dbdee91478bc228df9d5fe45864cc468a3f3aadc0883d025fa804c16fd3e2ca836ea113ad6373b73114141ea153f
diff --git a/app-misc/crunch/crunch-3.4.ebuild b/app-misc/crunch/crunch-3.4.ebuild
new file mode 100644
index 000000000000..edaf0f426163
--- /dev/null
+++ b/app-misc/crunch/crunch-3.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A wordlist generator"
+HOMEPAGE="http://sourceforge.net/projects/crunch-wordlist/"
+SRC_URI="mirror://sourceforge/crunch-wordlist/crunch-wordlist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+src_prepare() {
+ tc-export CC
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch_user
+}
+
+src_install(){
+ dobin crunch
+ doman crunch.1
+ insinto /usr/share/crunch
+ doins charset.lst
+}
diff --git a/app-misc/crunch/crunch-3.5.ebuild b/app-misc/crunch/crunch-3.5.ebuild
new file mode 100644
index 000000000000..2ea374039709
--- /dev/null
+++ b/app-misc/crunch/crunch-3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A wordlist generator"
+HOMEPAGE="http://sourceforge.net/projects/crunch-wordlist/"
+SRC_URI="mirror://sourceforge/crunch-wordlist/crunch-wordlist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install(){
+ dobin crunch
+ doman crunch.1
+ insinto /usr/share/crunch
+ doins charset.lst
+}
diff --git a/app-misc/crunch/crunch-3.6.ebuild b/app-misc/crunch/crunch-3.6.ebuild
new file mode 100644
index 000000000000..2ea374039709
--- /dev/null
+++ b/app-misc/crunch/crunch-3.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A wordlist generator"
+HOMEPAGE="http://sourceforge.net/projects/crunch-wordlist/"
+SRC_URI="mirror://sourceforge/crunch-wordlist/crunch-wordlist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install(){
+ dobin crunch
+ doman crunch.1
+ insinto /usr/share/crunch
+ doins charset.lst
+}
diff --git a/app-misc/crunch/files/crunch-3.4-gentoo.patch b/app-misc/crunch/files/crunch-3.4-gentoo.patch
new file mode 100644
index 000000000000..acdc757ef61d
--- /dev/null
+++ b/app-misc/crunch/files/crunch-3.4-gentoo.patch
@@ -0,0 +1,34 @@
+--- Makefile.orig 2013-11-21 11:53:21.835712927 +0400
++++ Makefile 2013-11-21 11:53:42.557713372 +0400
+@@ -16,19 +16,19 @@
+ # General variables
+ PACKAGE = crunch
+ VERSION = 3.4
+-PREFIX = /usr
++PREFIX ?= /usr
+ DISTDIR = $(PACKAGE)-$(VERSION)
+ DISTFILES = crunch.c crunch.1 charset.lst
+ BINDIR = $(PREFIX)/bin
+ BTBINDIR = /pentest/passwords/$(PACKAGE)
+ MANDIR = $(PREFIX)/share/man/man1
+ INSTALL = $(shell which install)
+-CC = $(shell which gcc)
++CC ?= $(shell which gcc)
+ LIBFLAGS = -lm
+ THREADFLAGS = -pthread
+ OPTFLAGS = -g -o0
+ LINTFLAGS = -Wall -pedantic
+-CFLAGS = $(THREADFLAGS) $(LINTFLAGS) -std=c99
++CFLAGS += $(THREADFLAGS) $(LINTFLAGS) -std=c99
+ VCFLAGS = $(THREADFLAGS) $(LINTFLAGS) -std=c99 $(OPTFLAGS)
+ LFS = $(shell getconf POSIX_V6_ILP32_OFFBIG_CFLAGS)
+ INSTALL_OPTIONS = -o root -g root
+@@ -46,7 +46,7 @@
+
+ crunch: crunch.c
+ @echo "Building binary..."
+- $(CC) $(CFLAGS) $(LFS) $? $(LIBFLAGS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LFS) $? $(LIBFLAGS) -o $@
+ @echo ""
+
+ # Clean target
diff --git a/app-misc/crunch/metadata.xml b/app-misc/crunch/metadata.xml
new file mode 100644
index 000000000000..92eb07b23869
--- /dev/null
+++ b/app-misc/crunch/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">crunch-wordlist</remote-id>
+ </upstream>
+</pkgmetadata>