summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/tmux-mem-cpu-load
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/tmux-mem-cpu-load')
-rw-r--r--app-misc/tmux-mem-cpu-load/Manifest2
-rw-r--r--app-misc/tmux-mem-cpu-load/metadata.xml11
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.1.0.ebuild38
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1-r1.ebuild29
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild26
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild26
6 files changed, 132 insertions, 0 deletions
diff --git a/app-misc/tmux-mem-cpu-load/Manifest b/app-misc/tmux-mem-cpu-load/Manifest
new file mode 100644
index 000000000000..339ceeaa86ed
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/Manifest
@@ -0,0 +1,2 @@
+DIST tmux-mem-cpu-load-2.1.0.tar.gz 2705 SHA256 846036b3d9b0f5e6b6e88988f483f0d82060ca2bbe9fbbd4f4d63ac287eccb7c SHA512 18db125eededc3b2d75f74563e2173daa9fd0a72a9e1eefa93010d3a338403a1393c1a49471e03703d0a72ce7a407070836e5f0486a19e83c02abe1bbec2d2b9 WHIRLPOOL fa64abb9f6e5f43311e13c7777dee835f0b75d9fef1c12c548d8705a86cc67cb18c1164d160d2ce216f8cea7d5b6ae9aae24f80fbac544bdcec20fa2011dbe94
+DIST tmux-mem-cpu-load-2.2.1.tar.gz 9893 SHA256 fd90bd8d66f275f4cae36dc5bd05a2826ca3be63a86b916ef7a2b9d956817b9d SHA512 44d677bbe9eb457b8857c603f469c46767878b2b8af8f169f2b01393ce65fc8da3c33288bc0743b3c2846b77de798437130a7676ca95c5cab52cd4166d9ded73 WHIRLPOOL 4512f46972cd7f3eb6c4881ac735b71a4084b3e8a66906d85d9761343617647477f8b4559860a9104b3eaecf2486aea5a2c8a7c7f0011c878c2114259eba5823
diff --git a/app-misc/tmux-mem-cpu-load/metadata.xml b/app-misc/tmux-mem-cpu-load/metadata.xml
new file mode 100644
index 000000000000..3ec619e87141
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wired@gentoo.org</email>
+ <name>Alex Alexander</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">thewtex/tmux-mem-cpu-load</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.1.0.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.1.0.ebuild
new file mode 100644
index 000000000000..efea556786c5
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit cmake-utils
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit git
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/thewtex/tmux-mem-cpu-load.git"}
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="amd64 x86"
+ SRC_URI="http://www.github.com/thewtex/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"
+HOMEPAGE="http://github.com/thewtex/tmux-mem-cpu-load/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+src_prepare() {
+ if [[ ${PV} == *9999* ]]; then
+ git_src_prepare
+ else
+ cd "${WORKDIR}"/thewtex-${PN}-*
+ S=$(pwd)
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.rst || die
+}
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1-r1.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..f974ec800d8c
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/thewtex/tmux-mem-cpu-load.git"}
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/thewtex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"
+HOMEPAGE="http://github.com/thewtex/tmux-mem-cpu-load/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.rst
+}
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild
new file mode 100644
index 000000000000..1cb6e7791abf
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-2.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit cmake-utils
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/thewtex/tmux-mem-cpu-load.git"}
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/thewtex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"
+HOMEPAGE="http://github.com/thewtex/tmux-mem-cpu-load/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DOCS=( README.rst )
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild
new file mode 100644
index 000000000000..503b44064e7b
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/thewtex/tmux-mem-cpu-load.git"}
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/thewtex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"
+HOMEPAGE="http://github.com/thewtex/tmux-mem-cpu-load/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DOCS=( README.rst )