summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-10 19:44:32 +0100
committerSam James <sam@gentoo.org>2021-07-10 19:47:27 +0100
commitcc40459a06ea0746e27e77f84e51754c7abafe08 (patch)
treeee853f955b6bc5bd6d14795df189e095028e05a3 /app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild
parentdev-lisp/ecls: add dev-libs/libffi subslot dep (diff)
downloadgentoo-cc40459a06ea0746e27e77f84e51754c7abafe08.tar.gz
gentoo-cc40459a06ea0746e27e77f84e51754c7abafe08.tar.bz2
gentoo-cc40459a06ea0746e27e77f84e51754c7abafe08.zip
app-shells/ctypes-sh: add dev-libs/libffi subslot dep
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild')
-rw-r--r--app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild b/app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild
new file mode 100644
index 000000000000..b4b3407a8bfb
--- /dev/null
+++ b/app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Foreign function interface for bash"
+HOMEPAGE="http://ctypes.sh/"
+SRC_URI="https://github.com/taviso/${PN/-/.}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ app-shells/bash[plugins(-)]
+ dev-libs/libffi:=
+ virtual/libelf
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ pushd test >/dev/null || die
+ PATH="${S}:${PATH}" \
+ LD_LIBRARY_PATH="${S}/src/.libs" \
+ make CC="$(tc-getCC)" || die "make check failed"
+ popd > /dev/null || die
+}