summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild')
-rw-r--r--app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild b/app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild
new file mode 100644
index 000000000000..b4b3407a8bfb
--- /dev/null
+++ b/app-shells/ctypes-sh/ctypes-sh-1.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Foreign function interface for bash"
+HOMEPAGE="http://ctypes.sh/"
+SRC_URI="https://github.com/taviso/${PN/-/.}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ app-shells/bash[plugins(-)]
+ dev-libs/libffi:=
+ virtual/libelf
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ pushd test >/dev/null || die
+ PATH="${S}:${PATH}" \
+ LD_LIBRARY_PATH="${S}/src/.libs" \
+ make CC="$(tc-getCC)" || die "make check failed"
+ popd > /dev/null || die
+}