summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-shells/gentoo-zsh-completions
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-shells/gentoo-zsh-completions')
-rw-r--r--app-shells/gentoo-zsh-completions/Manifest2
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild30
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20150103.ebuild28
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild28
-rw-r--r--app-shells/gentoo-zsh-completions/metadata.xml11
5 files changed, 99 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/Manifest b/app-shells/gentoo-zsh-completions/Manifest
new file mode 100644
index 000000000000..32180684f0c9
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/Manifest
@@ -0,0 +1,2 @@
+DIST gentoo-zsh-completions-20141115.tar.xz 19672 SHA256 8da688b38065728056a0557971894668657c029bf1127521eb088268c421bc27 SHA512 23debde6227574285ba123ad312db535d40813de686ef4c89f1e4cd9acb3c1ab63f5094194a50e6d272ad9ce3fa1ec6ef0bf4cf93424e2ec7adcb4c74572e420 WHIRLPOOL d22a5e897d4eb48e7191172f9da40c23b84f9fade10fb383e251562522b7b96c918af2de047a1a88ac385e13a6d0dc86fc1292dc9b7d5ad42696d48b618f6c21
+DIST gentoo-zsh-completions-20150103.tar.gz 23759 SHA256 b9636fe7a2d9b586437688c30b53efc6c005d2e4599a001af72ebb6cef772631 SHA512 4d87edda071d98672df79e3dbb9565757c0738bc50751d31e5dfefab4f17523387fb2342906ecc0600ce86d888ab4a785756bbb1daf37ca56a3ce1af9e5ae173 WHIRLPOOL 8b685bd0838f14feaed7a23c47b9af884a509fbf99db9d91cac39604671405f2e5a2e9e3945c6bd049f85a2ecde244c92bc8db2e72d4a9b852b021dd78fe8900
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild
new file mode 100644
index 000000000000..691941b0a87f
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20141115.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/radhermit/gentoo-zsh-completions"
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="ZSH"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins _*
+
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+ elog "to your shell."
+ elog
+}
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20150103.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20150103.ebuild
new file mode 100644
index 000000000000..28d819245c23
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20150103.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/radhermit/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/radhermit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/radhermit/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
new file mode 100644
index 000000000000..fb1666185293
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/radhermit/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/radhermit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/radhermit/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}
diff --git a/app-shells/gentoo-zsh-completions/metadata.xml b/app-shells/gentoo-zsh-completions/metadata.xml
new file mode 100644
index 000000000000..5e9d5c770f65
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">radhermit/gentoo-zsh-completions</remote-id>
+ </upstream>
+</pkgmetadata>