summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-07-24 10:05:22 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-24 10:06:38 +0200
commitc774dee9dcbc6c868a85d73ff32e937735a98caf (patch)
tree3ed3e7bd1fc22bc6b0844cac9dff2ac95e483757 /app-shells/zsh
parentapp-editors/texworks: Add missing dep on dev-qt/qtconcurrent (diff)
downloadgentoo-c774dee9dcbc6c868a85d73ff32e937735a98caf.tar.gz
gentoo-c774dee9dcbc6c868a85d73ff32e937735a98caf.tar.bz2
gentoo-c774dee9dcbc6c868a85d73ff32e937735a98caf.zip
app-shells/zsh: prefixify configure.ac.
Some tests, like /usr/bin/ypbind, captures host features and results in build failure. Closes: https://bugs.gentoo.org/690424 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Benda Xu <heroxbd@gentoo.org> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/zsh-5.7.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-shells/zsh/zsh-5.7.1.ebuild b/app-shells/zsh/zsh-5.7.1.ebuild
index 7455f1937729..103eb4abf6a4 100644
--- a/app-shells/zsh/zsh-5.7.1.ebuild
+++ b/app-shells/zsh/zsh-5.7.1.ebuild
@@ -3,10 +3,10 @@
EAPI=7
-inherit flag-o-matic prefix
+inherit autotools flag-o-matic prefix
if [[ ${PV} == 9999* ]] ; then
- inherit git-r3 autotools
+ inherit git-r3
EGIT_REPO_URI="https://git.code.sf.net/p/zsh/code"
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -64,10 +64,11 @@ src_prepare() {
default
+ hprefixify configure.ac
if [[ ${PV} == 9999* ]] ; then
sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
- eautoreconf
fi
+ eautoreconf
}
src_configure() {