summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-27 08:45:18 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-27 08:45:46 +0000
commitbc515668f79ba796b7563943bf3c175fca304ae3 (patch)
tree93590f6b58247863b3fce72a89bb26314ef000bc /app-shells
parentapp-shells/bashdb: EAPI 6 bump. (diff)
downloadgentoo-bc515668f79ba796b7563943bf3c175fca304ae3.tar.gz
gentoo-bc515668f79ba796b7563943bf3c175fca304ae3.tar.bz2
gentoo-bc515668f79ba796b7563943bf3c175fca304ae3.zip
app-shells/ccsh: EAPI 6 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r3.ebuild6
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r4.ebuild27
2 files changed, 30 insertions, 3 deletions
diff --git a/app-shells/ccsh/ccsh-0.0.4-r3.ebuild b/app-shells/ccsh/ccsh-0.0.4-r3.ebuild
index 926a02b4672e..5ca3aa0e471b 100644
--- a/app-shells/ccsh/ccsh-0.0.4-r3.ebuild
+++ b/app-shells/ccsh/ccsh-0.0.4-r3.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=4
inherit toolchain-funcs
DESCRIPTION="UNIX Shell for people already familiar with the C language"
HOMEPAGE="http://ccsh.sourceforge.net/"
-SRC_URI="http://download.sourceforge.net/ccsh/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/ccsh/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/app-shells/ccsh/ccsh-0.0.4-r4.ebuild b/app-shells/ccsh/ccsh-0.0.4-r4.ebuild
new file mode 100644
index 000000000000..405560327615
--- /dev/null
+++ b/app-shells/ccsh/ccsh-0.0.4-r4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="UNIX Shell for people already familiar with the C language"
+HOMEPAGE="http://ccsh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccsh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~ppc64"
+IUSE=""
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ exeinto /bin
+ doexe "${PN}"
+ newman "${PN}.man" "${PN}.1"
+ dodoc ChangeLog README TODO
+}