summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/code2html
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/code2html')
-rw-r--r--app-text/code2html/Manifest2
-rw-r--r--app-text/code2html/code2html-0.9.1-r1.ebuild41
-rw-r--r--app-text/code2html/code2html-0.9.1-r2.ebuild44
-rw-r--r--app-text/code2html/files/code2html-0.9.1-prefix.patch30
-rw-r--r--app-text/code2html/files/code2html-0.9.1-scalar.patch20
-rw-r--r--app-text/code2html/metadata.xml12
6 files changed, 149 insertions, 0 deletions
diff --git a/app-text/code2html/Manifest b/app-text/code2html/Manifest
new file mode 100644
index 000000000000..77268336b409
--- /dev/null
+++ b/app-text/code2html/Manifest
@@ -0,0 +1,2 @@
+DIST code2html-0.9.1-gentoo_patches.tar.bz2 2666 SHA256 e1a1ff10d861db2d52435e29707a7de0e779f0afeb6277cecde438cb98f12092 SHA512 cd478b53f0c11b9b4838a842bd8cb344698c85b1c3e09f03a75214f4002f4748a15f995530d6b6c743a4edb784c8aa703786ec10d3bda971b9485153e7090fdc WHIRLPOOL 7b7cbd9401a7cf1c7e815add7fb21c64927b80799a3cb3884968002f847145bf2d8417481190b217f6c1b3ae2e5bda09ffc8e71c9becf8f9e649f748dc8bab3a
+DIST code2html-0.9.1.tar.gz 39811 SHA256 f2fde58ba378766a21affc692eeac622aa1c6434f05c993aedf53203edec2d84 SHA512 97fb8cadfe64a389711c58b13b7b5d977849f3a242c32a2456f93d7abd39f5d0a4152416f5c73aa05f151316ea0d8486b2b9923a5390eefec3e9d8253cc0b2d3 WHIRLPOOL 949dea088ef02753b59b114d930bf02c4ae7ef14d23b2cc2df6d4dfd06e79b4e40cde043927ca9ab68f45edeb9b7ef25b6605ef2011d2af2b9cb09d9b69d8952
diff --git a/app-text/code2html/code2html-0.9.1-r1.ebuild b/app-text/code2html/code2html-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..696499147eda
--- /dev/null
+++ b/app-text/code2html/code2html-0.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils prefix
+
+DESCRIPTION="Converts source files to colored HTML output"
+HOMEPAGE="http://www.palfrader.org/code2html/"
+SRC_URI="http://www.palfrader.org/code2html/all/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo_patches.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5"
+
+src_prepare() {
+ # Be consistent in color codes (bug #119406)
+ epatch "${WORKDIR}"/${P}-lowercase_color_codes.patch
+
+ # Improved C++ support (bug #133159)
+ epatch "${WORKDIR}"/${P}-cpp_keywords.patch
+
+ # Improved Ada support (bug #133176)
+ epatch "${WORKDIR}"/${P}-ada_identifiers.patch
+
+ # For prefix paths
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify code2html
+}
+
+src_install() {
+ dobin code2html
+ dodoc ChangeLog CREDITS README
+ doman code2html.1
+}
diff --git a/app-text/code2html/code2html-0.9.1-r2.ebuild b/app-text/code2html/code2html-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..3c7e85052e65
--- /dev/null
+++ b/app-text/code2html/code2html-0.9.1-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils prefix
+
+DESCRIPTION="Converts source files to colored HTML output"
+HOMEPAGE="http://www.palfrader.org/code2html/"
+SRC_URI="http://www.palfrader.org/code2html/all/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo_patches.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5"
+
+src_prepare() {
+ # Be consistent in color codes (bug #119406)
+ epatch "${WORKDIR}"/${P}-lowercase_color_codes.patch
+
+ # Improved C++ support (bug #133159)
+ epatch "${WORKDIR}"/${P}-cpp_keywords.patch
+
+ # Improved Ada support (bug #133176)
+ epatch "${WORKDIR}"/${P}-ada_identifiers.patch
+
+ # For prefix paths
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify code2html
+
+ # For newer Perl, bug 523610
+ epatch "${FILESDIR}"/${P}-scalar.patch
+}
+
+src_install() {
+ dobin code2html
+ dodoc ChangeLog CREDITS README
+ doman code2html.1
+}
diff --git a/app-text/code2html/files/code2html-0.9.1-prefix.patch b/app-text/code2html/files/code2html-0.9.1-prefix.patch
new file mode 100644
index 000000000000..cc27296fb71c
--- /dev/null
+++ b/app-text/code2html/files/code2html-0.9.1-prefix.patch
@@ -0,0 +1,30 @@
+--- code2html
++++ code2html
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -w
++#!@GENTOO_PORTAGE_EPREFIX@/usr/bin/perl -w
+ use locale;
+ my $vernr = "0.9.1";
+ my $monthshort = "Jan";
+@@ -45,9 +45,9 @@
+ # PP: A hash would be nicer but then it would not possible to get the keys in this very order (AFAIK)
+ # PP: If names contain meta characters, then those must be metaquoted (if you don't want the meta chars to be meta chars of course)
+ my @CGI_ENCODING = (
+- ['bzip2' , '/usr/bin/bzip2' , '--stdout' ],
+- ['gzip' , '/bin/gzip' , '--stdout' ],
+- ['compress' , '/usr/bin/compress' , '-c' ]
++ ['bzip2' , '@GENTOO_PORTAGE_EPREFIX@/usr/bin/bzip2' , '--stdout' ],
++ ['gzip' , '@GENTOO_PORTAGE_EPREFIX@/bin/gzip' , '--stdout' ],
++ ['compress' , '@GENTOO_PORTAGE_EPREFIX@/usr/bin/compress' , '-c' ]
+ );
+
+
+@@ -147,7 +147,7 @@
+ # building up the database
+ # newer entries overwrite old ones
+ my @CONFIG_FILES;
+- push @CONFIG_FILES, "/etc/code2html.config";
++ push @CONFIG_FILES, "@GENTOO_PORTAGE_EPREFIX@/etc/code2html.config";
+ push @CONFIG_FILES, $ENV{'HOME'}."/.code2html.config" if (defined($ENV{'HOME'}));
+ push @CONFIG_FILES, split(/:/,$ENV{'CODE2HTML_CONFIG'}) if ($ENV{'CODE2HTML_CONFIG'});
+ push @CONFIG_FILES, split(/:/,$params{'langfile'}) if defined($params{'langfile'});
diff --git a/app-text/code2html/files/code2html-0.9.1-scalar.patch b/app-text/code2html/files/code2html-0.9.1-scalar.patch
new file mode 100644
index 000000000000..eddc89a6a8f7
--- /dev/null
+++ b/app-text/code2html/files/code2html-0.9.1-scalar.patch
@@ -0,0 +1,20 @@
+--- code2html.orig 2002-01-12 22:17:02.000000000 +0100
++++ code2html 2014-09-24 13:52:52.000000000 +0200
+@@ -1357,7 +1357,7 @@
+ my @lines = split ( /\n/, $_[0] );
+
+ my $nr = 0;
+- my $lengthofnr = length(@lines);
++ my $lengthofnr = length(scalar(@lines));
+ my $format = qq{<a name="$_[1]line%u">%${lengthofnr}u</a> %s\n} ;
+ join ('', map ( {$nr++; sprintf ( $format , $nr, $nr, $_ )} @lines));
+ },
+@@ -1367,7 +1367,7 @@
+ my @lines = split ( /\n/, $_[0] );
+
+ my $nr = 0;
+- my $lengthofnr = length(@lines);
++ my $lengthofnr = length(scalar(@lines));
+ my $format = qq{<a name="$_[1]line%u" href="#$_[1]line%u">%$ {lengthofnr}u</a> %s\n};
+ join ('', map ( {$nr++; sprintf ( $format , $nr, $nr, $nr, $_ )} @lines));
+ }
diff --git a/app-text/code2html/metadata.xml b/app-text/code2html/metadata.xml
new file mode 100644
index 000000000000..4a9d1f76cfa3
--- /dev/null
+++ b/app-text/code2html/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>
+ Code2HTML converts a program source code to syntax highlighted
+ HTML. It may be called as a CGI script. It can also handle include
+ commands in HTML files.
+</longdescription>
+</pkgmetadata>