summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-12 14:17:58 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-02 23:42:55 +0200
commitd58bfdf95954ce00b973f122b84dbfd74fbf5804 (patch)
tree4c43c9b5044230eb85a5ca7afb481214c6adee49 /app-vim/breakpts
parentapp-misc/cpipe: add amd64-fbsd keyword. (diff)
downloadgentoo-d58bfdf95954ce00b973f122b84dbfd74fbf5804.tar.gz
gentoo-d58bfdf95954ce00b973f122b84dbfd74fbf5804.tar.bz2
gentoo-d58bfdf95954ce00b973f122b84dbfd74fbf5804.zip
app-vim/breakpts: EAPI7, fix SRC_URI.
Closes: https://bugs.gentoo.org/665780 Closes: https://github.com/gentoo/gentoo/pull/9844 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim/breakpts')
-rw-r--r--app-vim/breakpts/Manifest1
-rw-r--r--app-vim/breakpts/breakpts-4.0-r2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/breakpts/Manifest b/app-vim/breakpts/Manifest
index d5cf63e70c21..b84e4d8728bc 100644
--- a/app-vim/breakpts/Manifest
+++ b/app-vim/breakpts/Manifest
@@ -1 +1,2 @@
DIST breakpts-4.0.tar.bz2 17349 BLAKE2B c7ad9eed8fb13537c940e6868f5e4e5dd812a6b7f7c26c4617e3c24905b6e2a817dc91990b613b700e793dd763a6841f85dd7f9cc42fb9f5afc25c3609f909fc SHA512 a480bf32cd3e756ac25849b1d5fd20521bd8c965454bb94c33810c9d1d4464762a731d08dcae858c59853a6cf41ab3cb6cddeda440c8b041cc8ec192ab2bd2fd
+DIST breakpts-4.0.zip 20124 BLAKE2B 2ea7568af5407d57c4d4b505c69d625056d62e8f5bd25bf5ca13918e3ffbc0f83de2aedb0abc3468215a650308ed8b592a618c0b50c24dd8ad3f931ef5d2ff8b SHA512 3e7f148896a10abd30a16d903c14460668ee48d078ae3c3b6ff663dab53d32199d8cf9cd3a56164a32d0be2684e64a882e917f3f632318ce85db5eb07e29754d
diff --git a/app-vim/breakpts/breakpts-4.0-r2.ebuild b/app-vim/breakpts/breakpts-4.0-r2.ebuild
new file mode 100644
index 000000000000..1dcdff18bc43
--- /dev/null
+++ b/app-vim/breakpts/breakpts-4.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sets vim breakpoints visually"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=618"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=8142 -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 )
+ >=app-vim/multvals-3.6.1
+ >=app-vim/genutils-1.13
+ >=app-vim/foldutil-1.6"
+DEPEND="app-arch/unzip"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin allows breakpoints to be set and cleared visually. To start,
+use :BreakPts, move to the required function and press <CR>. Breakpoints
+can then be added using :BPToggle or <F9>."