summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-08-18 11:01:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-08-18 11:01:53 -0500
commit671687695b73fd1fb36cc45e2a40a1afacf5923c (patch)
tree7cf7601e11f49af98a2b831a277ffec446829531 /dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {3.14.76,4.4.18,4.6.7,4... (diff)
downloadgentoo-671687695b73fd1fb36cc45e2a40a1afacf5923c.tar.gz
gentoo-671687695b73fd1fb36cc45e2a40a1afacf5923c.tar.bz2
gentoo-671687695b73fd1fb36cc45e2a40a1afacf5923c.zip
dev-cpp/cpp-hocon: adding as it's now needed by puppety things
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild')
-rw-r--r--dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild b/dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild
new file mode 100644
index 000000000000..60ce3d2cc5b0
--- /dev/null
+++ b/dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Provides C++ support for the HOCON configuration file format"
+HOMEPAGE="https://github.com/puppetlabs/cpp-hocon"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+DEPEND="
+ >=sys-devel/gcc-5.0:*
+ >=dev-libs/boost-1.57[nls]
+ dev-libs/leatherman
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # make it support multilib
+ sed -i "s/\ lib)/\ $(get_libdir))/g" lib/CMakeLists.txt || die
+ sed -i "s/lib\")/$(get_libdir)\")/g" CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ )
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}