summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-21 01:11:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-21 01:11:41 +0200
commite396408c30767babb730a3b80fb6866d458642a4 (patch)
treef2f996386712b41ff8ac1ad5199728bb472eac27 /dev-dotnet
parentwww-apps/chromedriver-bin: add 103.0.5060.134 (diff)
downloadgentoo-e396408c30767babb730a3b80fb6866d458642a4.tar.gz
gentoo-e396408c30767babb730a3b80fb6866d458642a4.tar.bz2
gentoo-e396408c30767babb730a3b80fb6866d458642a4.zip
dev-dotnet/dotnet-sdk-bin: icu optfeature
Closes: https://bugs.gentoo.org/833281 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.420.ebuild8
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.421.ebuild8
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.407-r1.ebuild8
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408.ebuild8
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.301.ebuild8
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.302.ebuild8
6 files changed, 48 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.420.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.420.ebuild
index dabeb4bdbf70..595560460cba 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.420.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.420.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit optfeature
+
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -46,3 +48,9 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
+
+pkg_postinst() {
+ # For bug #833281 Also, MS docs:
+ # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
+ optfeature "globalization support" dev-libs/icu
+}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.421.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.421.ebuild
index dabeb4bdbf70..595560460cba 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.421.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.421.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit optfeature
+
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -46,3 +48,9 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
+
+pkg_postinst() {
+ # For bug #833281 Also, MS docs:
+ # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
+ optfeature "globalization support" dev-libs/icu
+}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.407-r1.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.407-r1.ebuild
index 35084c97d1ab..0a495504107e 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.407-r1.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.407-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit optfeature
+
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -49,3 +51,9 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
+
+pkg_postinst() {
+ # For bug #833281 Also, MS docs:
+ # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
+ optfeature "globalization support" dev-libs/icu
+}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408.ebuild
index 35084c97d1ab..0a495504107e 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.408.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit optfeature
+
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -49,3 +51,9 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
+
+pkg_postinst() {
+ # For bug #833281 Also, MS docs:
+ # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
+ optfeature "globalization support" dev-libs/icu
+}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.301.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.301.ebuild
index 4a71ab6b42e1..5983f350bfe8 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.301.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.301.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit optfeature
+
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -56,3 +58,9 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
+
+pkg_postinst() {
+ # For bug #833281 Also, MS docs:
+ # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
+ optfeature "globalization support" dev-libs/icu
+}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.302.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.302.ebuild
index 4a71ab6b42e1..5983f350bfe8 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.302.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.302.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit optfeature
+
MY_PV="${PV}"
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
@@ -56,3 +58,9 @@ src_install() {
doenvd "${T}/90${PN}-${SLOT}"
fi
}
+
+pkg_postinst() {
+ # For bug #833281 Also, MS docs:
+ # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
+ optfeature "globalization support" dev-libs/icu
+}