summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-02 00:02:02 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-02 00:02:02 +0100
commit4f9b1087d1a8f39ebd8673d5bb6acd8673697423 (patch)
tree8fb25e0c2aae421d2da2109844e9b733ca6adca0 /dev-haskell/cryptonite
parentdev-haskell/uuagc: remove unused patch(es) (diff)
downloadgentoo-4f9b1087d1a8f39ebd8673d5bb6acd8673697423.tar.gz
gentoo-4f9b1087d1a8f39ebd8673d5bb6acd8673697423.tar.bz2
gentoo-4f9b1087d1a8f39ebd8673d5bb6acd8673697423.zip
dev-haskell/cryptonite: switch to CPU_CLAGS_X86_* IUSEs
Reported-by: Michał Górny Closes: https://bugs.gentoo.org/695058 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/cryptonite')
-rw-r--r--dev-haskell/cryptonite/Manifest2
-rw-r--r--dev-haskell/cryptonite/cryptonite-0.21.ebuild20
-rw-r--r--dev-haskell/cryptonite/cryptonite-0.7.ebuild41
-rw-r--r--dev-haskell/cryptonite/cryptonite-0.8.ebuild41
-rw-r--r--dev-haskell/cryptonite/metadata.xml8
5 files changed, 12 insertions, 100 deletions
diff --git a/dev-haskell/cryptonite/Manifest b/dev-haskell/cryptonite/Manifest
index dd91d1325c76..d72d3a2bd548 100644
--- a/dev-haskell/cryptonite/Manifest
+++ b/dev-haskell/cryptonite/Manifest
@@ -1,3 +1 @@
DIST cryptonite-0.21.tar.gz 615850 BLAKE2B df5f0273fa40b5401e4bb5df7c4cd5839ab87fdff3d2cef6be80c977433a1adbcdbf1c9d42f79987e4a7a590f8179fd998f93017af396116e10554108566b028 SHA512 7f04ad5f7411bf90f343c13b71438fdd0e1e40cc5c9a5f1553c1f396a278f81cbe3a548ee8bc03b3b63bc66485ce36dc9a93c3dc3e5884f601bbae49efa98cc3
-DIST cryptonite-0.7.tar.gz 324734 BLAKE2B b0eabfa2575ed4680de541b5acafa1cc7d95ed5e7faca3ea53dddfdeea98a69ca76d7ea65e6117a8f6faf3c43a0b8f3a39c200e975279a78366140d80d663aff SHA512 077b181b1563087c6c04816a36bfd2efd7a732f72b02e5277f3d987093954ca8e420814b547c7c985418e74e8c838a3c8381b4821f3ed6fa8412b63078fade0e
-DIST cryptonite-0.8.tar.gz 325531 BLAKE2B b62d1330de4305e2a7c48063f1745d8f47ef176d356c07b2d533dbdfe02d4d76bd5699f8dda0f258108b2c16b2cf4bbe8228f4565620125839101e721310a05a SHA512 c393e7a93f8d4368ae9ee3130eb44cbc0a4937fdbe27bb918a8900716d9946bae39897717b1c2b3c2531ce69562df3d3260177fa76a6f90ee53ace206fe382a3
diff --git a/dev-haskell/cryptonite/cryptonite-0.21.ebuild b/dev-haskell/cryptonite/cryptonite-0.21.ebuild
index 773ab90c605c..dd0416afc7ed 100644
--- a/dev-haskell/cryptonite/cryptonite-0.21.ebuild
+++ b/dev-haskell/cryptonite/cryptonite-0.21.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# ebuild generated by hackport 0.5.1.9999
-#hackport: flags: -check_alignment,-old_toolchain_inliner
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -check_alignment,-old_toolchain_inliner,+support_deepseq,support_aesni:cpu_flags_x86_aes,support_pclmuldq:cpu_flags_x86_sse4_1,support_sse:cpu_flags_x86_sse,support_rdrand:cpu-flags-x86-rdrand,support_blake2_sse:cpu_flags_x86_sse
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -15,8 +15,8 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="+integer-gmp +support_aesni support_blake2_sse +support_deepseq support_pclmuldq +support_rdrand"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cpu-flags-x86-rdrand +cpu_flags_x86_aes cpu_flags_x86_sse cpu_flags_x86_sse4_1 +integer-gmp"
RDEPEND=">=dev-haskell/memory-0.8:=[profile?]
>=dev-lang/ghc-7.4.1:=
@@ -35,9 +35,9 @@ src_configure() {
--flag=-check_alignment \
$(cabal_flag integer-gmp integer-gmp) \
--flag=-old_toolchain_inliner \
- $(cabal_flag support_aesni support_aesni) \
- $(cabal_flag support_blake2_sse support_blake2_sse) \
- $(cabal_flag support_deepseq support_deepseq) \
- $(cabal_flag support_pclmuldq support_pclmuldq) \
- $(cabal_flag support_rdrand support_rdrand)
+ $(cabal_flag cpu_flags_x86_aes support_aesni) \
+ $(cabal_flag cpu_flags_x86_sse support_blake2_sse) \
+ --flag=support_deepseq \
+ $(cabal_flag cpu_flags_x86_sse4_1 support_pclmuldq) \
+ $(cabal_flag cpu-flags-x86-rdrand support_rdrand)
}
diff --git a/dev-haskell/cryptonite/cryptonite-0.7.ebuild b/dev-haskell/cryptonite/cryptonite-0.7.ebuild
deleted file mode 100644
index bf70362d04a2..000000000000
--- a/dev-haskell/cryptonite/cryptonite-0.7.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Cryptography Primitives sink"
-HOMEPAGE="https://github.com/vincenthz/cryptonite"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+integer-gmp +support_aesni +support_deepseq support_pclmuldq +support_rdrand"
-
-RESTRICT=test # slow
-
-RDEPEND=">=dev-haskell/memory-0.8:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
- test? ( dev-haskell/byteable
- dev-haskell/tasty
- dev-haskell/tasty-hunit
- dev-haskell/tasty-kat
- dev-haskell/tasty-quickcheck )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag integer-gmp integer-gmp) \
- $(cabal_flag support_aesni support_aesni) \
- $(cabal_flag support_deepseq support_deepseq) \
- $(cabal_flag support_pclmuldq support_pclmuldq) \
- $(cabal_flag support_rdrand support_rdrand)
-}
diff --git a/dev-haskell/cryptonite/cryptonite-0.8.ebuild b/dev-haskell/cryptonite/cryptonite-0.8.ebuild
deleted file mode 100644
index 08d4a6767c3b..000000000000
--- a/dev-haskell/cryptonite/cryptonite-0.8.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Cryptography Primitives sink"
-HOMEPAGE="https://github.com/haskell-crypto/cryptonite"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+integer-gmp +support_aesni +support_deepseq support_pclmuldq +support_rdrand"
-
-RESTRICT=test # slow
-
-RDEPEND=">=dev-haskell/memory-0.8:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
- test? ( dev-haskell/byteable
- dev-haskell/tasty
- dev-haskell/tasty-hunit
- dev-haskell/tasty-kat
- dev-haskell/tasty-quickcheck )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag integer-gmp integer-gmp) \
- $(cabal_flag support_aesni support_aesni) \
- $(cabal_flag support_deepseq support_deepseq) \
- $(cabal_flag support_pclmuldq support_pclmuldq) \
- $(cabal_flag support_rdrand support_rdrand)
-}
diff --git a/dev-haskell/cryptonite/metadata.xml b/dev-haskell/cryptonite/metadata.xml
index 2558232f1f8f..c845b334ecdc 100644
--- a/dev-haskell/cryptonite/metadata.xml
+++ b/dev-haskell/cryptonite/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
@@ -29,12 +29,8 @@
Evaluate the security related to your requirements before using.
</longdescription>
<use>
- <flag name="support_aesni">allow compilation with AESNI on system and architecture that supports it</flag>
- <flag name="support_rdrand">allow compilation with AESNI on system and architecture that supports it</flag>
- <flag name="support_pclmuldq">Allow compilation with pclmuldq on architecture that supports it</flag>
+ <flag name="cpu-flags-x86-rdrand">allow compilation with RDRAND on system and architecture that supports it</flag>
<flag name="integer-gmp">Whether or not to use GMP for some functions</flag>
- <flag name="support_deepseq">add deepseq instances for cryptographic types</flag>
- <flag name="support_blake2_sse">Use SSE optimized version of BLAKE2</flag>
</use>
<upstream>
<remote-id type="github">haskell-crypto/cryptonite</remote-id>