summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-06 11:39:52 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-06 12:02:57 +0000
commitafc683ae6c02e67c26b7ed1126623d05185a655c (patch)
tree564b36043ef4784529a5cd33589be907c7815927 /dev-haskell
parentdev-haskell/shelly: bump up to 1.6.8.1 (diff)
downloadgentoo-afc683ae6c02e67c26b7ed1126623d05185a655c.tar.gz
gentoo-afc683ae6c02e67c26b7ed1126623d05185a655c.tar.bz2
gentoo-afc683ae6c02e67c26b7ed1126623d05185a655c.zip
dev-haskell/shellish: tweak for ghc-8
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch9
-rw-r--r--dev-haskell/shellish/shellish-0.1.4.ebuild3
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch b/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch
new file mode 100644
index 000000000000..49525543acbd
--- /dev/null
+++ b/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch
@@ -0,0 +1,9 @@
+diff --git a/Shellish.hs b/Shellish.hs
+index 0ac20c2..7de0e11 100644
+--- a/Shellish.hs
++++ b/Shellish.hs
+@@ -180,3 +180,3 @@ test_s = path >=> liftIO . \f -> do
+ stat <- getSymbolicLinkStatus f
+- return $ isSymbolicLink stat
++ return $ System.PosixCompat.Files.isSymbolicLink stat
+
diff --git a/dev-haskell/shellish/shellish-0.1.4.ebuild b/dev-haskell/shellish/shellish-0.1.4.ebuild
index f93d8797cc7a..55236c96777e 100644
--- a/dev-haskell/shellish/shellish-0.1.4.ebuild
+++ b/dev-haskell/shellish/shellish-0.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,4 +27,5 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+ epatch "${FILESDIR}"/${P}-ghc-8.patch
}