summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch9
-rw-r--r--dev-haskell/shellish/shellish-0.1.4.ebuild3
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch b/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch
new file mode 100644
index 000000000000..49525543acbd
--- /dev/null
+++ b/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch
@@ -0,0 +1,9 @@
+diff --git a/Shellish.hs b/Shellish.hs
+index 0ac20c2..7de0e11 100644
+--- a/Shellish.hs
++++ b/Shellish.hs
+@@ -180,3 +180,3 @@ test_s = path >=> liftIO . \f -> do
+ stat <- getSymbolicLinkStatus f
+- return $ isSymbolicLink stat
++ return $ System.PosixCompat.Files.isSymbolicLink stat
+
diff --git a/dev-haskell/shellish/shellish-0.1.4.ebuild b/dev-haskell/shellish/shellish-0.1.4.ebuild
index f93d8797cc7a..55236c96777e 100644
--- a/dev-haskell/shellish/shellish-0.1.4.ebuild
+++ b/dev-haskell/shellish/shellish-0.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,4 +27,5 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+ epatch "${FILESDIR}"/${P}-ghc-8.patch
}