summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-03-09 11:12:46 +0100
committerUlrich Müller <ulm@gentoo.org>2020-03-09 11:14:44 +0100
commitdda5d7b4cc3822b54784b47cb53066cf95908608 (patch)
treeae659192de7a37be1b2407b7c80b45d23f32b08a /dev-lang/c-intercal
parentdev-lang/c-intercal: Fix build with -fno-common. (diff)
downloadgentoo-dda5d7b4cc3822b54784b47cb53066cf95908608.tar.gz
gentoo-dda5d7b4cc3822b54784b47cb53066cf95908608.tar.bz2
gentoo-dda5d7b4cc3822b54784b47cb53066cf95908608.zip
dev-lang/c-intercal: Remove old.
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lang/c-intercal')
-rw-r--r--dev-lang/c-intercal/Manifest1
-rw-r--r--dev-lang/c-intercal/c-intercal-30.0.ebuild76
-rw-r--r--dev-lang/c-intercal/files/c-intercal-30.0-version.patch11
-rw-r--r--dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch17
4 files changed, 0 insertions, 105 deletions
diff --git a/dev-lang/c-intercal/Manifest b/dev-lang/c-intercal/Manifest
index 16c9559dd0f4..0ac55ab591e2 100644
--- a/dev-lang/c-intercal/Manifest
+++ b/dev-lang/c-intercal/Manifest
@@ -1,2 +1 @@
-DIST intercal-0.30.tar.gz 930759 BLAKE2B c8c9b77c31901da8f7dbd5a76c2d6fa900962c69f4ca56835f750f40370d5161f6311cbe5473cdb7342772c1cc5317e51d91e174cb16985565adacd001fc1f29 SHA512 e82f52082a73e0eb6116026f78fdcc38369f54af828b9ed0d3ca6ed6c40550bfa81db4ca7c4d09015b5db5104a1c06229cfed52e1d202c3a7443f933fbcc0498
DIST intercal-0.31.tar.gz 940950 BLAKE2B 9a23229b1d7f0524b164a4b66bcab4fdf67a04ba1e411365a46a90d646867fe92d6e328935b406673809535a895becde934fb6cf2e8380943eb8f19473fcedab SHA512 ca5c10be880ce2470d7dd3404fa5a314bd7bcab45cf4908f7108eb1baa50339b876e135251d991527881b564027c63dc38d74a154cbd00d606261013d2b01262
diff --git a/dev-lang/c-intercal/c-intercal-30.0.ebuild b/dev-lang/c-intercal/c-intercal-30.0.ebuild
deleted file mode 100644
index dc79132dad03..000000000000
--- a/dev-lang/c-intercal/c-intercal-30.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools elisp-common
-
-# C-INTERCAL uses minor-major ordering of version components and
-# negative version numbers. We map version components -1, -2, ...
-# to 65535, 65534, ..., and subtract one from the next component.
-# For example, upstream version 0.28 is mapped to Gentoo version 28.0
-# and 0.-2.0.29 is mapped to 28.65535.65534.0.
-get_intercal_version() {
- local i=.${1:-${PV}} j k c=0
- while [[ ${i} ]]; do
- (( k = ${i##*.} + c ))
- (( (c = (k >= 32768)) && (k -= 65536) ))
- i=${i%.*}
- j=${j}.${k}
- done
- echo ${j#.}
-}
-
-MY_PN="${PN#c-}"
-MY_PV="$(get_intercal_version)"
-DESCRIPTION="C-INTERCAL - INTERCAL to binary (via C) compiler"
-HOMEPAGE="http://www.catb.org/~esr/intercal/"
-SRC_URI="http://www.catb.org/~esr/intercal/${MY_PN}-${MY_PV}.tar.gz"
-
-LICENSE="GPL-2+ FDL-1.2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="emacs examples"
-
-RDEPEND="emacs? ( >=app-editors/emacs-23.1:* )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/yacc"
-
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- eapply "${FILESDIR}"/${P}-version.patch
- eapply "${FILESDIR}"/${P}-yywrap.patch
- eapply_user
- eautoreconf
-}
-
-src_compile() {
- emake
-
- if use emacs; then
- elisp-compile etc/intercal.el
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc BUGS NEWS HISTORY README doc/THEORY.txt
-
- if use emacs; then
- elisp-install ${PN} etc/intercal.{el,elc}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- use examples && dodoc -r pit
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/c-intercal/files/c-intercal-30.0-version.patch b/dev-lang/c-intercal/files/c-intercal-30.0-version.patch
deleted file mode 100644
index 3fe8d026e23a..000000000000
--- a/dev-lang/c-intercal/files/c-intercal-30.0-version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- intercal-0.30-orig/configure.ac
-+++ intercal-0.30/configure.ac
-@@ -14,7 +14,7 @@
- subdir-objects no-texinfo.tex -Wall -Wno-override])
-
- dnl Information about this version of INTERCAL.
--PACKAGE_VERSION=0.29
-+PACKAGE_VERSION=0.30
-
- dnl Checks for programs.
- AC_PROG_YACC
diff --git a/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch b/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch
deleted file mode 100644
index 9d46a91beceb..000000000000
--- a/dev-lang/c-intercal/files/c-intercal-30.0-yywrap.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://bugs.gentoo.org/604848
-
---- intercal-0.30-orig/src/lexer.l
-+++ intercal-0.30/src/lexer.l
-@@ -38,12 +38,10 @@
- /*#undef wchar_t*/
- /*#define wchar_t unsigned char*/
-
--#ifndef yywrap
- static int yywrap(void)
- {
- return 1;
- }
--#endif /* yywrap */
-
- int iyylineno = 1;
-