summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-05-18 12:22:40 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-05-18 12:23:02 -0500
commit39807b1e2e146b4599f68d07a9fd41bad7f62404 (patch)
tree9833179b3ef5dbdebfa00688e03e4dd58c5a1499 /dev-lang
parentsys-auth/keystone: fix CVE-2016-4911 bug 583392 (diff)
downloadgentoo-39807b1e2e146b4599f68d07a9fd41bad7f62404.tar.gz
gentoo-39807b1e2e146b4599f68d07a9fd41bad7f62404.tar.bz2
gentoo-39807b1e2e146b4599f68d07a9fd41bad7f62404.zip
dev-lang/go: apply patch for #581072
Gdb was starting by spawning a shell and this was causing issues for the tests. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/files/go-1.6.1-gdb-no-shell.patch12
-rw-r--r--dev-lang/go/files/go-1.6.2-gdb-no-shell.patch12
-rw-r--r--dev-lang/go/go-1.6.1.ebuild5
-rw-r--r--dev-lang/go/go-1.6.2.ebuild5
4 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/go/files/go-1.6.1-gdb-no-shell.patch b/dev-lang/go/files/go-1.6.1-gdb-no-shell.patch
new file mode 100644
index 000000000000..ccce6f04664d
--- /dev/null
+++ b/dev-lang/go/files/go-1.6.1-gdb-no-shell.patch
@@ -0,0 +1,12 @@
+diff --git a/src/runtime/runtime-gdb_test.go b/src/runtime/runtime-gdb_test.go
+index 6ebc69a..648092a 100644
+--- a/src/runtime/runtime-gdb_test.go
++++ b/src/runtime/runtime-gdb_test.go
+@@ -87,6 +87,7 @@ func TestGdbPython(t *testing.T) {
+
+ args := []string{"-nx", "-q", "--batch", "-iex",
+ fmt.Sprintf("add-auto-load-safe-path %s/src/runtime", runtime.GOROOT()),
++ "-ex", "set startup-with-shell off",
+ "-ex", "info auto-load python-scripts",
+ "-ex", "br main.go:10",
+ "-ex", "run",
diff --git a/dev-lang/go/files/go-1.6.2-gdb-no-shell.patch b/dev-lang/go/files/go-1.6.2-gdb-no-shell.patch
new file mode 100644
index 000000000000..ccce6f04664d
--- /dev/null
+++ b/dev-lang/go/files/go-1.6.2-gdb-no-shell.patch
@@ -0,0 +1,12 @@
+diff --git a/src/runtime/runtime-gdb_test.go b/src/runtime/runtime-gdb_test.go
+index 6ebc69a..648092a 100644
+--- a/src/runtime/runtime-gdb_test.go
++++ b/src/runtime/runtime-gdb_test.go
+@@ -87,6 +87,7 @@ func TestGdbPython(t *testing.T) {
+
+ args := []string{"-nx", "-q", "--batch", "-iex",
+ fmt.Sprintf("add-auto-load-safe-path %s/src/runtime", runtime.GOROOT()),
++ "-ex", "set startup-with-shell off",
+ "-ex", "info auto-load python-scripts",
+ "-ex", "br main.go:10",
+ "-ex", "run",
diff --git a/dev-lang/go/go-1.6.1.ebuild b/dev-lang/go/go-1.6.1.ebuild
index c70fc26e5293..4fce12b9de36 100644
--- a/dev-lang/go/go-1.6.1.ebuild
+++ b/dev-lang/go/go-1.6.1.ebuild
@@ -80,6 +80,11 @@ if [[ ${PV} != 9999 ]]; then
S="${WORKDIR}"/go
fi
+PATCHES=(
+# patch for #581072
+ "${FILESDIR}"/${P}-gdb-no-shell.patch
+)
+
go_arch()
{
# By chance most portage arch names match Go
diff --git a/dev-lang/go/go-1.6.2.ebuild b/dev-lang/go/go-1.6.2.ebuild
index 9a52b39fd524..ddf85db6008f 100644
--- a/dev-lang/go/go-1.6.2.ebuild
+++ b/dev-lang/go/go-1.6.2.ebuild
@@ -81,6 +81,11 @@ if [[ ${PV} != 9999 ]]; then
S="${WORKDIR}"/go
fi
+PATCHES=(
+# patch for #581072
+ "${FILESDIR}"/${P}-gdb-no-shell.patch
+)
+
go_arch()
{
# By chance most portage arch names match Go