summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/files/go-1.6.1-gdb-no-shell.patch12
-rw-r--r--dev-lang/go/files/go-1.6.2-gdb-no-shell.patch12
-rw-r--r--dev-lang/go/go-1.6.1.ebuild5
-rw-r--r--dev-lang/go/go-1.6.2.ebuild5
4 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/go/files/go-1.6.1-gdb-no-shell.patch b/dev-lang/go/files/go-1.6.1-gdb-no-shell.patch
new file mode 100644
index 000000000000..ccce6f04664d
--- /dev/null
+++ b/dev-lang/go/files/go-1.6.1-gdb-no-shell.patch
@@ -0,0 +1,12 @@
+diff --git a/src/runtime/runtime-gdb_test.go b/src/runtime/runtime-gdb_test.go
+index 6ebc69a..648092a 100644
+--- a/src/runtime/runtime-gdb_test.go
++++ b/src/runtime/runtime-gdb_test.go
+@@ -87,6 +87,7 @@ func TestGdbPython(t *testing.T) {
+
+ args := []string{"-nx", "-q", "--batch", "-iex",
+ fmt.Sprintf("add-auto-load-safe-path %s/src/runtime", runtime.GOROOT()),
++ "-ex", "set startup-with-shell off",
+ "-ex", "info auto-load python-scripts",
+ "-ex", "br main.go:10",
+ "-ex", "run",
diff --git a/dev-lang/go/files/go-1.6.2-gdb-no-shell.patch b/dev-lang/go/files/go-1.6.2-gdb-no-shell.patch
new file mode 100644
index 000000000000..ccce6f04664d
--- /dev/null
+++ b/dev-lang/go/files/go-1.6.2-gdb-no-shell.patch
@@ -0,0 +1,12 @@
+diff --git a/src/runtime/runtime-gdb_test.go b/src/runtime/runtime-gdb_test.go
+index 6ebc69a..648092a 100644
+--- a/src/runtime/runtime-gdb_test.go
++++ b/src/runtime/runtime-gdb_test.go
+@@ -87,6 +87,7 @@ func TestGdbPython(t *testing.T) {
+
+ args := []string{"-nx", "-q", "--batch", "-iex",
+ fmt.Sprintf("add-auto-load-safe-path %s/src/runtime", runtime.GOROOT()),
++ "-ex", "set startup-with-shell off",
+ "-ex", "info auto-load python-scripts",
+ "-ex", "br main.go:10",
+ "-ex", "run",
diff --git a/dev-lang/go/go-1.6.1.ebuild b/dev-lang/go/go-1.6.1.ebuild
index c70fc26e5293..4fce12b9de36 100644
--- a/dev-lang/go/go-1.6.1.ebuild
+++ b/dev-lang/go/go-1.6.1.ebuild
@@ -80,6 +80,11 @@ if [[ ${PV} != 9999 ]]; then
S="${WORKDIR}"/go
fi
+PATCHES=(
+# patch for #581072
+ "${FILESDIR}"/${P}-gdb-no-shell.patch
+)
+
go_arch()
{
# By chance most portage arch names match Go
diff --git a/dev-lang/go/go-1.6.2.ebuild b/dev-lang/go/go-1.6.2.ebuild
index 9a52b39fd524..ddf85db6008f 100644
--- a/dev-lang/go/go-1.6.2.ebuild
+++ b/dev-lang/go/go-1.6.2.ebuild
@@ -81,6 +81,11 @@ if [[ ${PV} != 9999 ]]; then
S="${WORKDIR}"/go
fi
+PATCHES=(
+# patch for #581072
+ "${FILESDIR}"/${P}-gdb-no-shell.patch
+)
+
go_arch()
{
# By chance most portage arch names match Go