summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-10 16:19:59 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-11 09:01:59 +0100
commit41d9a5788023970d4c2fe2c216dc46221d98dc8d (patch)
tree50965a93f68bd23ba060813fcc5b7ee67401f4d2 /dev-lang
parentdev-lang/nim: drop old 1.6.6-r3 (diff)
downloadgentoo-41d9a5788023970d4c2fe2c216dc46221d98dc8d.tar.gz
gentoo-41d9a5788023970d4c2fe2c216dc46221d98dc8d.tar.bz2
gentoo-41d9a5788023970d4c2fe2c216dc46221d98dc8d.zip
dev-lang/nim: bump to 1.6.12
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nim/Manifest1
-rw-r--r--dev-lang/nim/nim-1.6.12.ebuild198
2 files changed, 199 insertions, 0 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index a76838169d04..d9c126dfd5c7 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1,4 +1,5 @@
DIST nim-1.6.10.tar.xz 5216284 BLAKE2B d5b7bdc488086260b84700e3022ff7fc45b98d78574a3d2e288c95968a580fa644e47612dc60d6e63f5e85687f5b59a28128be746abc55bd6d4527344dc3ab14 SHA512 2ba6c4db68030ace2b4dd9b7f85d2b7c882c62e8f7f68bd0b82f548c91c300ab0e03c66f56c678127058f56b75a5550dec48d68eb6d666a179994cd1a6e2cc47
+DIST nim-1.6.12.tar.xz 5180496 BLAKE2B d7c04ffdde273336770d9397dd255b7cfc442f6be9592afbfa5ceb1ac7836a8213d5cea673477ab55bd56c004cc477a6023b6a2799715f46689f3e328302e433 SHA512 17c31024ee19dfa36f25bf8a5091992b24a4adb1a817246119a2fc552075999f698a92e66243ddd5ee69d966deead37535c9aac00ebece3854c930f905eeb030
DIST nim-1.6.8.tar.xz 5219880 BLAKE2B 16eac6f302b4ef1df14deaa0350e0e5553c7613515cc3e79cbe025af70955bef29c8261a1f91ba901023d9c53f9f00d62116301eb5a4ee4bb5314bb1e25a5755 SHA512 dd046dd393136fdcb78f463e267756bdb990b08e80e3a8be7fec1995b47a930447468e12bb9a59db6ec5546117f62ff4ccd032959879ef2d1d06a7bc5c438f83
DIST nim-patches-1.6.6.tar.gz 1975 BLAKE2B 75490f4c61f4d920aadb2ad5908cb2773e270f80cee95f937ede8125bad5688b71840ed7f48659db892e4017437a0454b38eab18ae8b13c6b48207d0a7714371 SHA512 4d1590e7d05ad64432b943f8da9edb2b05213400181d1e07a0e40f479afbceb1997d0ea0f05a73d550afe60cf4b657f7e34840907ea16c3b9e96824e9f29e0e5
DIST nim-patches-1.6.6_p1.tar.gz 2632 BLAKE2B 64980d9510dc48e3c566473dc618d00cafba04783882d62b12015e8435c9c0515d7726da30f0b74dca6a41aa88a9c9aed2189a65b3325c28839d0051de8a3365 SHA512 7ba251675cd564452669bf5ec3748565db818324f58506f20a5036e4b54df10f4d7c149cece8cb97c853222cfa7d4d8d26856d92aaa25e613e31c6f5c2a8243d
diff --git a/dev-lang/nim/nim-1.6.12.ebuild b/dev-lang/nim/nim-1.6.12.ebuild
new file mode 100644
index 000000000000..675ddf78b6f6
--- /dev/null
+++ b/dev-lang/nim/nim-1.6.12.ebuild
@@ -0,0 +1,198 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PATCH_PV="1.6.6_p1"
+
+inherit bash-completion-r1 edo multiprocessing toolchain-funcs xdg-utils
+
+DESCRIPTION="Compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/"
+SRC_URI="
+ https://nim-lang.org/download/${P}.tar.xz
+ experimental? (
+ https://git.sr.ht/~cyber/${PN}-patches/archive/${PATCH_PV}.tar.gz
+ -> nim-patches-${PATCH_PV}.tar.gz
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc experimental test-js test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-db/sqlite:3
+ dev-libs/boehm-gc
+ dev-libs/libffi
+ dev-libs/libpcre:3
+ dev-libs/openssl
+ media-libs/libsdl
+ media-libs/libsfml
+ )
+"
+BDEPEND="
+ sys-process/parallel
+ test? (
+ test-js? (
+ net-libs/nodejs
+ )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.20.0-paths.patch
+ "${FILESDIR}"/${PN}-1.6.6-csources-flags.patch
+)
+
+# Borrowed from nim-utils.eclass (guru overlay).
+nim_gen_config() {
+ cat > nim.cfg <<- EOF || die "Failed to create Nim config"
+ cc:"gcc"
+ gcc.exe:"$(tc-getCC)"
+ gcc.linkerexe:"$(tc-getCC)"
+ gcc.cpp.exe:"$(tc-getCXX)"
+ gcc.cpp.linkerexe:"$(tc-getCXX)"
+ gcc.options.speed:"${CFLAGS}"
+ gcc.options.size:"${CFLAGS}"
+ gcc.options.debug:"${CFLAGS}"
+ gcc.options.always:"${CPPFLAGS}"
+ gcc.options.linker:"${LDFLAGS}"
+ gcc.cpp.options.speed:"${CXXFLAGS}"
+ gcc.cpp.options.size:"${CXXFLAGS}"
+ gcc.cpp.options.debug:"${CXXFLAGS}"
+ gcc.cpp.options.always:"${CPPFLAGS}"
+ gcc.cpp.options.linker:"${LDFLAGS}"
+
+ $([[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && echo '--colors:"off"')
+ -d:"release"
+ --parallelBuild:"$(makeopts_jobs)"
+
+ # some tests don't work with processing hints
+ --processing:"off"
+ EOF
+}
+
+src_prepare() {
+ default
+
+ # note: there are consumers in the ::guru overlay
+ use experimental && eapply "${WORKDIR}"/nim-patches-${PATCH_PV}
+}
+
+src_configure() {
+ xdg_environment_reset # bug 667182
+
+ unset NIMBLE_DIR
+ tc-export CC CXX LD
+
+ nim_gen_config
+
+ mkdir "${HOME}"/.parallel || die
+ touch "${HOME}"/.parallel/will-cite || die "parallel setup failed"
+}
+
+src_compile() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ edo ./build.sh --parallel "$(makeopts_jobs)"
+
+ ebegin "Waiting for unfinished jobs"
+ while [[ ! -f "bin/nim" ]]; do
+ sleep 1
+ done
+ eend 0
+
+ edo ./bin/nim compile koch
+ edo ./koch boot -d:nimUseLinenoise --skipParentCfg:off
+ edo ./koch tools
+
+ if use doc; then
+ local -a docargs=(
+ # set git tag
+ --git.commit:v${PV}
+ # skip runnableExamples as some of them need net
+ --docCmd:skip
+ # make logs less verbose
+ --hints:off
+ --warnings:off
+ )
+ edo ./koch doc "${docargs[@]}"
+ HTML_DOCS=( web/upload/${PV}/. )
+ fi
+}
+
+src_test() {
+ local -x PATH="${S}/bin:${PATH}"
+ local -a nimflags=(
+ # Leave only the safe hints enabled.
+ --hint:all:off
+ --hint:User:on
+ --hint:UserRaw:on
+ )
+ local -a testament_args=(
+ --skipFrom:"${FILESDIR}/${PN}-1.6.10-testament-skipfile.txt"
+ --nim:"bin/nim"
+ --targets:"$(usex test-js 'c js' 'c')"
+ )
+
+ [[ "${NOCOLOR}" == true || "${NOCOLOR}" == yes ]] && \
+ testament_args+=( --colors:off )
+
+ local -a categories
+ readarray -t categories < <(find tests -mindepth 1 -maxdepth 1 -type d -printf "%P\n" | sort)
+
+ # AdditionalCategories from "testament/categories.nim".
+ categories+=( debugger examples lib )
+
+ local tcat checkpoint
+ for tcat in "${categories[@]}"; do
+ # Use checkpoints for less painful testing.
+ checkpoint="${T}/.testament-${tcat}"
+ [[ -f "${checkpoint}" ]] && continue
+
+ case ${tcat} in
+ testdata )
+ :
+ ;;
+ arc | ic | valgrind )
+ einfo "Skipped category '${tcat}'"
+ ;;
+ * )
+ einfo "Running tests in category '${tcat}'"
+ edo ./bin/testament "${testament_args[@]}" \
+ category "${tcat}" "${nimflags[@]}"
+ ;;
+ esac
+
+ touch "${checkpoint}" || die
+ done
+}
+
+src_install() {
+ local -x PATH="${S}/bin:${PATH}"
+
+ edo ./koch install "${ED}"
+ einstalldocs
+
+ # "./koch install" installs only "nim" binary but not the rest.
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == bin/nim ]] && continue
+ dobin "${exe}"
+ done
+
+ newbashcomp tools/nim.bash-completion nim
+ newbashcomp dist/nimble/nimble.bash-completion nimble
+
+ insinto /usr/share/zsh/site-functions
+ newins tools/nim.zsh-completion _nim
+ newins dist/nimble/nimble.zsh-completion _nimble
+
+ # Install the @nim-rebuild set for Portage.
+ insinto /usr/share/portage/config/sets
+ newins "${FILESDIR}"/nim-sets.conf nim.conf
+}