summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-21 07:47:03 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-21 11:08:24 +0100
commitea9c71b3c0b9a157e73f19eb7d96a93e6191a8e7 (patch)
tree238d5b67c81a077d8e0458c18a2180fb22df4820 /dev-libs/libgit2
parentdev-libs/libgit2: Bump to 0.99.0 (diff)
downloadgentoo-ea9c71b3c0b9a157e73f19eb7d96a93e6191a8e7.tar.gz
gentoo-ea9c71b3c0b9a157e73f19eb7d96a93e6191a8e7.tar.bz2
gentoo-ea9c71b3c0b9a157e73f19eb7d96a93e6191a8e7.zip
dev-libs/libgit2: Remove unmaintained live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libgit2')
-rw-r--r--dev-libs/libgit2/libgit2-0.99.0.ebuild19
-rw-r--r--dev-libs/libgit2/libgit2-9999.ebuild70
2 files changed, 9 insertions, 80 deletions
diff --git a/dev-libs/libgit2/libgit2-0.99.0.ebuild b/dev-libs/libgit2/libgit2-0.99.0.ebuild
index 23bd171e3106..3abe4784a16c 100644
--- a/dev-libs/libgit2/libgit2-0.99.0.ebuild
+++ b/dev-libs/libgit2/libgit2-0.99.0.ebuild
@@ -6,19 +6,14 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
inherit cmake python-any-r1
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
-fi
-
DESCRIPTION="A linkable library for Git"
HOMEPAGE="https://libgit2.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${P/_/-}
LICENSE="GPL-2-with-linking-exception"
-SLOT="0/28"
+SLOT="0/0.99"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
IUSE="examples gssapi libressl +ssh test +threads trace"
RESTRICT="!test? ( test )"
@@ -35,7 +30,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
-S=${WORKDIR}/${P/_/-}
+src_prepare() {
+ cmake_src_prepare
+ # relying on forked http-parser to support some obscure URI form
+ sed -i -e '/empty_port/s:test:_&:' tests/network/urlparse.c || die
+}
src_configure() {
local mycmakeargs=(
diff --git a/dev-libs/libgit2/libgit2-9999.ebuild b/dev-libs/libgit2/libgit2-9999.ebuild
deleted file mode 100644
index 41394dc15ba1..000000000000
--- a/dev-libs/libgit2/libgit2-9999.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-any-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.org"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/28"
-IUSE="examples gssapi libressl +ssh test +threads trace"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- sys-libs/zlib
- net-libs/http-parser:=
- gssapi? ( virtual/krb5 )
- ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-src_configure() {
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
- -DBUILD_CLAR=$(usex test)
- -DENABLE_TRACE=$(usex trace)
- -DUSE_GSSAPI=$(usex gssapi)
- -DUSE_SSH=$(usex ssh)
- -DTHREADSAFE=$(usex threads)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- if [[ ${EUID} -eq 0 ]] ; then
- # repo::iterator::fs_preserves_error fails if run as root
- # since root can still access dirs with 0000 perms
- ewarn "Skipping tests: non-root privileges are required for all tests to pass"
- else
- local TEST_VERBOSE=1
- cmake-utils_src_test -R offline
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc docs/*.{md,txt}
-
- if use examples ; then
- find examples -name '.gitignore' -delete || die
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}