summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-11-10 17:26:36 -0600
committerWilliam Hubbs <williamh@gentoo.org>2015-11-11 11:39:44 -0600
commitdf089e8574d565fac82aecb90664c9d511eac60b (patch)
treebf11246a81dab61a7fd84bdfbf8e6a9d593af593 /dev-lua
parentdev-lua/mediator_lua: initial commit (diff)
downloadgentoo-df089e8574d565fac82aecb90664c9d511eac60b.tar.gz
gentoo-df089e8574d565fac82aecb90664c9d511eac60b.tar.bz2
gentoo-df089e8574d565fac82aecb90664c9d511eac60b.zip
dev-lua/penlight: initial commit
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/penlight/Manifest1
-rw-r--r--dev-lua/penlight/metadata.xml14
-rw-r--r--dev-lua/penlight/penlight-1.3.2.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-lua/penlight/Manifest b/dev-lua/penlight/Manifest
new file mode 100644
index 000000000000..f426045bb4a1
--- /dev/null
+++ b/dev-lua/penlight/Manifest
@@ -0,0 +1 @@
+DIST penlight-1.3.2-core.zip 116854 SHA256 553c937011063a9eb5a2234bd3d5d7896c77990ca41693ca317d20b2af961c4d SHA512 01ba35e967e255f6f39afff9c2238f4921de9e52850ce0d2ec0c9068029fc61a241c82bede680a28fda46c4504582784fcd2241a2eef0bef95c7c389c4042d02 WHIRLPOOL 6e4c7e14294d0837f799b58d703826de7e2d4a6212f4e8f15e52c9cd4e3f80d82a6389c4bba92c3a1efbbc2bda8e5fbd3d907ebcb1fd6ba0216cebde9a13ba22
diff --git a/dev-lua/penlight/metadata.xml b/dev-lua/penlight/metadata.xml
new file mode 100644
index 000000000000..4a880815e99f
--- /dev/null
+++ b/dev-lua/penlight/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ Penlight is a set of pure Lua libraries for making it easier to work
+ with common tasks like iterating over directories, reading
+ configuration files and the like. Provides functional operations
+ on tables and sequences.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-lua/penlight/penlight-1.3.2.ebuild b/dev-lua/penlight/penlight-1.3.2.ebuild
new file mode 100644
index 000000000000..7536d1ca5390
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="http://stevedonovan.github.com/Penlight",
+SRC_URI="http://stevedonovan.github.io/files/${PN}-1.3.2-core.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+app-arch/unzip
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ dev-lua/luafilesystem"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r lua/pl
+}