summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-28 14:44:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-28 14:45:08 +0200
commit2e92f2133a0f7af9498a876b2f1d0a2743c9ba94 (patch)
tree57f779704133b0e9336d4dc01b1d87358e5675b9 /dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
parentdev-ros/rqt_robot_monitor: bump to 0.5.8 (diff)
downloadgentoo-2e92f2133a0f7af9498a876b2f1d0a2743c9ba94.tar.gz
gentoo-2e92f2133a0f7af9498a876b2f1d0a2743c9ba94.tar.bz2
gentoo-2e92f2133a0f7af9498a876b2f1d0a2743c9ba94.zip
dev-ml/ocaml-mysql: bump to 1.2.2
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild')
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
new file mode 100644
index 000000000000..a1afca457cf1
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION || die
+}