summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-11-01 22:18:30 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-11-01 22:18:30 +0100
commit1259579a303b3397efa95e9868c02d17d601d524 (patch)
tree900976a2bcc87c9cd18ad36f8e2d8ce08913ed8d /dev-perl/Quota
parentdev-lang/perl: Dont include xlocale.h in perl.h, bug 636206 (diff)
downloadgentoo-1259579a303b3397efa95e9868c02d17d601d524.tar.gz
gentoo-1259579a303b3397efa95e9868c02d17d601d524.tar.bz2
gentoo-1259579a303b3397efa95e9868c02d17d601d524.zip
dev-perl/Quota: Fix build with glibc-2.26, bug 630568
Not sure if this is complete though... it compiles, but does it run? Closes: https://bugs.gentoo.org/630568 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-perl/Quota')
-rw-r--r--dev-perl/Quota/Quota-1.7.2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-perl/Quota/Quota-1.7.2.ebuild b/dev-perl/Quota/Quota-1.7.2.ebuild
index 9b1c897be014..7e107a67f8fd 100644
--- a/dev-perl/Quota/Quota-1.7.2.ebuild
+++ b/dev-perl/Quota/Quota-1.7.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=TOMZO
-inherit perl-module
+inherit perl-module toolchain-funcs flag-o-matic
DESCRIPTION="Perl interface to file system quotas"
@@ -12,14 +12,19 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-RDEPEND=""
-DEPEND="virtual/perl-ExtUtils-MakeMaker"
+RDEPEND="
+ sys-fs/quota[rpc]
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
# Tests need real FS access/root permissions and are interactive
DIST_TEST=skip
src_prepare() {
default
+ export mymake="OPTIMIZE=$($(tc-getPKG_CONFIG) --cflags libtirpc)"
# disable AFS completely for now, need somebody who can really test it
sed -i -e 's|-d "/afs"|0|' Makefile.PL || die "sed failed"