summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/RadiusPerl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/RadiusPerl')
-rw-r--r--dev-perl/RadiusPerl/Manifest1
-rw-r--r--dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild44
-rw-r--r--dev-perl/RadiusPerl/files/dictionary.cisco.ssg.patch14
-rw-r--r--dev-perl/RadiusPerl/metadata.xml9
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/RadiusPerl/Manifest b/dev-perl/RadiusPerl/Manifest
new file mode 100644
index 000000000000..8a5fc4ccf6d9
--- /dev/null
+++ b/dev-perl/RadiusPerl/Manifest
@@ -0,0 +1 @@
+DIST RadiusPerl-0.22.tar.gz 40980 SHA256 3b276506986ccaa4949d92b13ce053a0017ad11562a991cc753364923fe81ca7 SHA512 d5c7327fa3d4b6f74405e905f01be23479be542073d035c3babc34b63577069f6069e44dda9709b69b5dc25552170a764eb02ab6d2b6c2f7b366da566ae8e967 WHIRLPOOL cb55655e83579b7d59556d39a20e305f486a784b9258f2285cca1f6448e9b6ca59de3550dbfaa4f75984da5c5ebe3213ef5d6615cff72e8f2528479dfe7fe83d
diff --git a/dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild b/dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild
new file mode 100644
index 000000000000..5195e6c30ced
--- /dev/null
+++ b/dev-perl/RadiusPerl/RadiusPerl-0.220.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MANOWAR
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~sparc x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.12
+ >=dev-perl/Data-HexDump-0.02
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/Authen-Radius-${MODULE_VERSION}
+
+SRC_TEST="do"
+export OPTIMIZE="$CFLAGS"
+PATCHES=( "${FILESDIR}"/dictionary.cisco.ssg.patch )
+
+src_prepare() {
+ sed -i '/install-radius-db.PL/d' Makefile.PL MANIFEST || die
+ mv "${S}"/install-radius-db.PL{,.orig} || die
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}
diff --git a/dev-perl/RadiusPerl/files/dictionary.cisco.ssg.patch b/dev-perl/RadiusPerl/files/dictionary.cisco.ssg.patch
new file mode 100644
index 000000000000..bbec7052ff67
--- /dev/null
+++ b/dev-perl/RadiusPerl/files/dictionary.cisco.ssg.patch
@@ -0,0 +1,14 @@
+--- /etc/raddb/dictionary.cisco 2010-02-10 01:04:00.000000000 +0200
++++ dictionary.cisco 2010-02-10 01:06:10.000000000 +0200
+@@ -118,3 +118,11 @@
+ VALUE Cisco-Disconnect-Cause Session-End-Callback 102
+ VALUE Cisco-Disconnect-Cause Invalid-Protocol 120
+
++#ISG Support http://www.cisco.com/en/US/docs/ios/12_2sb/isg/coa/guide/isgcaapa.html
++ATTRIBUTE Cisco-Policy-Up 37 string Cisco
++ATTRIBUTE Cisco-Policy-Down 38 string Cisco
++ATTRIBUTE Cisco-SSG-Subscriber-Password 249 string Cisco
++ATTRIBUTE Cisco-SSG-Account-Info 250 string Cisco
++ATTRIBUTE Cisco-SSG-Service-Info 251 string Cisco
++ATTRIBUTE Cisco-SSG-Command-Code 252 string Cisco
++ATTRIBUTE Cisco-SSG-Control-Info 253 string Cisco
diff --git a/dev-perl/RadiusPerl/metadata.xml b/dev-perl/RadiusPerl/metadata.xml
new file mode 100644
index 000000000000..a5e667e78563
--- /dev/null
+++ b/dev-perl/RadiusPerl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">RadiusPerl</remote-id>
+ <remote-id type="cpan-module">Authen::Radius</remote-id>
+ </upstream>
+</pkgmetadata>