summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-02 17:25:25 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-02 17:25:25 +0200
commit10bba174e37e72ae18f9c72a515c8e2c9a6a590a (patch)
tree349ae5f4c26469049ff70dc75897435f0452dc60 /dev-perl
parentdev-perl/Pod-Readme: Add build fix for Perl 5.26, bug 623074 (diff)
downloadgentoo-10bba174e37e72ae18f9c72a515c8e2c9a6a590a.tar.gz
gentoo-10bba174e37e72ae18f9c72a515c8e2c9a6a590a.tar.bz2
gentoo-10bba174e37e72ae18f9c72a515c8e2c9a6a590a.zip
dev-perl/Pod-Tests: Add build fix for Perl 5.26, bug 623076
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild b/dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild
index 8b3d49e6f884..ca9f05940b4c 100644
--- a/dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild
+++ b/dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR=ADAMK
-MODULE_VERSION=1.19
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.19
inherit perl-module
DESCRIPTION="Extracts embedded tests and code examples from POD"
@@ -16,4 +16,8 @@ IUSE=""
RDEPEND="virtual/perl-File-Spec"
DEPEND="${RDEPEND}"
-SRC_TEST="do"
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}