summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-08-22 16:20:00 -0400
committerBrian Evans <grknight@gentoo.org>2018-08-22 16:20:00 -0400
commit6257de8fba4cf42cd43a1a755ea3de345fbe2b89 (patch)
treeb95acacc7e36fb089da1bf7236e906b195210158 /dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild
parentdev-php/PEAR-PEAR: Version bump to 1.10.6 (diff)
downloadgentoo-6257de8fba4cf42cd43a1a755ea3de345fbe2b89.tar.gz
gentoo-6257de8fba4cf42cd43a1a755ea3de345fbe2b89.tar.bz2
gentoo-6257de8fba4cf42cd43a1a755ea3de345fbe2b89.zip
dev-php/PEAR-Archive_Tar: Version bump for 1.4.3
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild')
-rw-r--r--dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild
new file mode 100644
index 000000000000..25b31991dcc7
--- /dev/null
+++ b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tar file management class"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# bzip2 and zlib are needed for compressed tarballs, and there's one
+# call to preg_match to test paths against a pattern of files and
+# directories that will be ignored.
+RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
+PDEPEND="dev-php/PEAR-PEAR"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Archive
+
+ dodoc docs/*
+}