summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2016-11-24 08:43:17 +0100
committerMichael Orlitzky <mjo@gentoo.org>2016-12-18 18:17:02 -0500
commit7597666e5c4129648723a953e015eb082fc53495 (patch)
tree806bd362cd89a7e989a352183830b127cb4ef89f /dev-php/ca-bundle/ca-bundle-1.0.0.ebuild
parentdev-php/semver: Add 1.0.0 version (diff)
downloadgentoo-7597666e5c4129648723a953e015eb082fc53495.tar.gz
gentoo-7597666e5c4129648723a953e015eb082fc53495.tar.bz2
gentoo-7597666e5c4129648723a953e015eb082fc53495.zip
dev-php/ca-bundle: Add 1.0.0 version
This is needed for composer-1.2.2, bug 439206. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/ca-bundle/ca-bundle-1.0.0.ebuild')
-rw-r--r--dev-php/ca-bundle/ca-bundle-1.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/ca-bundle/ca-bundle-1.0.0.ebuild b/dev-php/ca-bundle/ca-bundle-1.0.0.ebuild
new file mode 100644
index 000000000000..7e6cbf7924a3
--- /dev/null
+++ b/dev-php/ca-bundle/ca-bundle-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Find a path to the system CA bundle, and fallback to the Mozilla CA bundle"
+HOMEPAGE="https://github.com/composer/ca-bundle"
+SRC_URI="https://github.com/composer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/Composer/CaBundle"
+ doins -r src/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}