summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/libchart
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/libchart')
-rw-r--r--dev-php/libchart/Manifest2
-rw-r--r--dev-php/libchart/libchart-1.2.2.ebuild34
-rw-r--r--dev-php/libchart/libchart-1.3.ebuild34
-rw-r--r--dev-php/libchart/metadata.xml8
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-php/libchart/Manifest b/dev-php/libchart/Manifest
new file mode 100644
index 000000000000..4732d7248b36
--- /dev/null
+++ b/dev-php/libchart/Manifest
@@ -0,0 +1,2 @@
+DIST libchart-1.2.2.tar.gz 103063 SHA256 3a369f3d0caf18cb2fa25db9744f2d7986c5020a474ca6b42ef807785bd78166 SHA512 6b86be1afdf4492e911c7c4bb08045d4f4f7229204a53c77339a8a7c5aa896c221e7bd9fe6bac2be05f97de653372689e22827ec1c13ee63402e9058818969bf WHIRLPOOL 033297a4d323729579240c17559d2765fb910e951c71f07b6a8f6f19dc98c84e2fd0f6e62489c7fa6f18da1229903bd51889e4c079088d529bea16d36c4797df
+DIST libchart-1.3.tar.gz 106204 SHA256 ab3bdf1ccdb008a7ca9f7908d7ed8698163ab6679eaaf4bc37d5229471f38ac2 SHA512 5d2a0b014546487029f552f225fa83de856210a997e69bb5b129e99790f5acfdcfff904077126c42f82974d10f81e7e0342991221af5f108902b2792df24d586 WHIRLPOOL e4bb9b86939592a97bec0b00ebc26046a599a9b6d1ed266db9ad7b6b4a653cca21fdb7aa31078ba2d0957ddc0cc0c5741fd1d62a80b229b55f78dda81c2acca9
diff --git a/dev-php/libchart/libchart-1.2.2.ebuild b/dev-php/libchart/libchart-1.2.2.ebuild
new file mode 100644
index 000000000000..dd6595d35955
--- /dev/null
+++ b/dev-php/libchart/libchart-1.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Libchart is a chart creation PHP library that is easy to use"
+HOMEPAGE="http://naku.dohcrew.com/libchart"
+SRC_URI="http://libchart.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~x86 ~amd64"
+SLOT=0
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-lang/php[truetype]
+ || ( dev-lang/php[gd] dev-lang/php[gd-external] )"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ dodoc "${PN}/ChangeLog" "${PN}/README"
+ rm -f "${PN}/ChangeLog" "${PN}/ChangeLog" "${PN}/COPYING"
+
+ if use examples ; then
+ # no point making users unzip all files individually
+ docompress -x "/usr/share/doc/${PF}/demo"
+ dodoc -r demo/
+ fi
+
+ insinto "/usr/share/php/${PN}"
+ doins -r ${PN}
+}
diff --git a/dev-php/libchart/libchart-1.3.ebuild b/dev-php/libchart/libchart-1.3.ebuild
new file mode 100644
index 000000000000..dd6595d35955
--- /dev/null
+++ b/dev-php/libchart/libchart-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Libchart is a chart creation PHP library that is easy to use"
+HOMEPAGE="http://naku.dohcrew.com/libchart"
+SRC_URI="http://libchart.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~x86 ~amd64"
+SLOT=0
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-lang/php[truetype]
+ || ( dev-lang/php[gd] dev-lang/php[gd-external] )"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ dodoc "${PN}/ChangeLog" "${PN}/README"
+ rm -f "${PN}/ChangeLog" "${PN}/ChangeLog" "${PN}/COPYING"
+
+ if use examples ; then
+ # no point making users unzip all files individually
+ docompress -x "/usr/share/doc/${PF}/demo"
+ dodoc -r demo/
+ fi
+
+ insinto "/usr/share/php/${PN}"
+ doins -r ${PN}
+}
diff --git a/dev-php/libchart/metadata.xml b/dev-php/libchart/metadata.xml
new file mode 100644
index 000000000000..64a54cc50bcb
--- /dev/null
+++ b/dev-php/libchart/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <upstream>
+ <remote-id type="google-code">libchart</remote-id>
+ </upstream>
+</pkgmetadata>