summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-01-07 09:28:34 -0500
committerBrian Evans <grknight@gentoo.org>2022-01-07 09:34:00 -0500
commit5da9fa558b0aa96b2c4036c81e07cea18d7402bc (patch)
treec86494081cd3a84a54da9e9f08b9b6d7dc452ab7 /dev-php
parentdev-php/PHP_Timer: Drop old (diff)
downloadgentoo-5da9fa558b0aa96b2c4036c81e07cea18d7402bc.tar.gz
gentoo-5da9fa558b0aa96b2c4036c81e07cea18d7402bc.tar.bz2
gentoo-5da9fa558b0aa96b2c4036c81e07cea18d7402bc.zip
dev-php/PHP_Timer: Version bump for 5.0.3
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHP_Timer/Manifest1
-rw-r--r--dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild31
-rw-r--r--dev-php/PHP_Timer/files/autoload-5.0.3.php18
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-php/PHP_Timer/Manifest b/dev-php/PHP_Timer/Manifest
index e502bf2d2ae4..29415f02a66d 100644
--- a/dev-php/PHP_Timer/Manifest
+++ b/dev-php/PHP_Timer/Manifest
@@ -1 +1,2 @@
DIST PHP_Timer-2.1.2.tar.gz 7090 BLAKE2B c99dd69433b3579e9ed81f06188cac280b6ac383bce12acd9c6a00b5a6d6017a94c427692b639ad1516c1faebec8e160b7cd5c7e5e96043dd3dcb6d283d2095b SHA512 199175e048560756867180cd99a3ca1766431d14091f1448cd8011df5f7824504a6c586ef15d9e53374bdb9dbd1731c05b44509e59d92d725908ec2c46d7d576
+DIST PHP_Timer-5.0.3.tar.gz 5363 BLAKE2B b63d438eab1dd5d872a1a632f1861d216dbdd7ab073a8fa36bad7f93134fd0c98ef7eb049189aeb6373b60eba592cc5add0044ac577d0b9728f3f78156dae914 SHA512 e1642cd0d247a49981f142b6975339c4abaf26cf4847783f309a0a15ba7a55520c7d1e11a87ea9b923337a9972f4dc95ee11121484a75c9c7a20882f664e8ba5
diff --git a/dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild b/dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild
new file mode 100644
index 000000000000..2ce617845f94
--- /dev/null
+++ b/dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="php-timer"
+
+DESCRIPTION="Utility class for timing"
+HOMEPAGE="https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*"
+
+src_install() {
+ insinto /usr/share/php/PHP/Timer
+ doins -r src/*
+ newins "${FILESDIR}/autoload-5.0.3.php" autoload.php
+}
+
+pkg_postinst() {
+ ewarn "This library now loads via /usr/share/php/PHP/Timer/autoload.php"
+ ewarn "Please update any scripts to require the autoloader"
+}
diff --git a/dev-php/PHP_Timer/files/autoload-5.0.3.php b/dev-php/PHP_Timer/files/autoload-5.0.3.php
new file mode 100644
index 000000000000..45b65b6045e8
--- /dev/null
+++ b/dev-php/PHP_Timer/files/autoload-5.0.3.php
@@ -0,0 +1,18 @@
+<?php
+/* Autoloader for dev-php/PHP_Timer */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ [
+ 'sebastianbergmann\timer\duration' => '/Duration.php',
+ 'sebastianbergmann\timer\exception' => '/exceptions/Exception.php',
+ 'sebastianbergmann\timer\noactivetimerexception' => '/exceptions/NoActiveTimerException.php',
+ 'sebastianbergmann\timer\resourceusageformatter' => '/ResourceUsageFormatter.php',
+ 'sebastianbergmann\timer\timer' => '/Timer.php',
+ 'sebastianbergmann\timer\timesincestartofrequestnotavailableexception' => '/exceptions/TimeSinceStartOfRequestNotAvailableException.php',
+ ],
+ __DIR__
+);