summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-16 15:08:09 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-16 17:00:00 -0500
commita46e68ce01a88185686db7e1bbd0b95f43b8ee0c (patch)
treef625043501c778ffbe9d99b214fc8b48e9139735 /dev-php
parentdev-php/PEAR-File: Revbump adding tests, EAPI and eclass changes (diff)
downloadgentoo-a46e68ce01a88185686db7e1bbd0b95f43b8ee0c.tar.gz
gentoo-a46e68ce01a88185686db7e1bbd0b95f43b8ee0c.tar.bz2
gentoo-a46e68ce01a88185686db7e1bbd0b95f43b8ee0c.zip
dev-php/PEAR-File_Fortune: Revbump to add tests and for EAPI/eclass
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild (renamed from dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0.ebuild)16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0.ebuild b/dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild
index 1e33656d0fea..ec5a405cb607 100644
--- a/dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0.ebuild
+++ b/dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild
@@ -1,16 +1,20 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit php-pear-r1
+inherit php-pear-r2
DESCRIPTION="Interface for reading from and writing to fortune files"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="test"
-DEPEND=">=dev-lang/php-5.1.4:*"
-RDEPEND="${DEPEND}"
+RDEPEND=">=dev-lang/php-5.1.4:*"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_test(){
+ phpunit tests || die
+}