summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/chardet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/Manifest2
-rw-r--r--dev-python/chardet/chardet-2.2.1.ebuild20
-rw-r--r--dev-python/chardet/chardet-2.3.0.ebuild20
-rw-r--r--dev-python/chardet/metadata.xml9
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
new file mode 100644
index 000000000000..606cee0ec5d5
--- /dev/null
+++ b/dev-python/chardet/Manifest
@@ -0,0 +1,2 @@
+DIST chardet-2.2.1.tar.gz 180319 SHA256 f1964f73f5ee9b7e0309098b9512d587fbba6dd5d1f3797b1c95529e5241bf09 SHA512 87059b77b14c39fded7f1287f8eeab6a880e21f4b49a3aa103daf537bbb1e237069347e1953ebaa9a393bd4dee01993873c84aad3c00536ae34784686aecfe68 WHIRLPOOL 1cd6838823f8effd502c3049d13966ac0888bdb91b34489caea8666f9802967fe6f86565ed827e609cb614c920cc9f983bdecc27c30bb2abcf4420731a0a620e
+DIST chardet-2.3.0.tar.gz 164346 SHA256 e53e38b3a4afe6d1132de62b7400a4ac363452dc5dfcf8d88e8e0cce663c68aa SHA512 d554c9b4564905a2b6c6971aaea2a812174d86b58137c6a2f9d54e2abd2395e6529968b2ce3ca2d97c717d2bd0bd80ab5b98cae9afac1a4add9ea305145030dd WHIRLPOOL af17bac2778a86d6fe9643a512a307cbcf92e4b43238b2d3d2bae53e646fccbdf40f31f41f9452e7d4f4c84d1ee637199af841a828d49f3452190749fee284c1
diff --git a/dev-python/chardet/chardet-2.2.1.ebuild b/dev-python/chardet/chardet-2.2.1.ebuild
new file mode 100644
index 000000000000..2b973d8962f1
--- /dev/null
+++ b/dev-python/chardet/chardet-2.2.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="https://github.com/chardet/chardet http://pypi.python.org/pypi/chardet"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/chardet/chardet-2.3.0.ebuild b/dev-python/chardet/chardet-2.3.0.ebuild
new file mode 100644
index 000000000000..3bbb8ecbb079
--- /dev/null
+++ b/dev-python/chardet/chardet-2.3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="https://github.com/chardet/chardet http://pypi.python.org/pypi/chardet"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/chardet/metadata.xml b/dev-python/chardet/metadata.xml
new file mode 100644
index 000000000000..d5228ef57d2a
--- /dev/null
+++ b/dev-python/chardet/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">chardet</remote-id>
+ <remote-id type="github">chardet/chardet</remote-id>
+ </upstream>
+</pkgmetadata>