summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-12 08:45:47 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-12 09:56:45 +0100
commit39af814cbd66ce25e15a6df225731f24ec50ae41 (patch)
treeb4ff8512e566e7b32f1a9ee4cbc68939623d541b /dev-python/dbus-python
parentdev-lang/swi-prolog: remove old development versions (diff)
downloadgentoo-39af814cbd66ce25e15a6df225731f24ec50ae41.tar.gz
gentoo-39af814cbd66ce25e15a6df225731f24ec50ae41.tar.bz2
gentoo-39af814cbd66ce25e15a6df225731f24ec50ae41.zip
dev-python/dbus-python: Use impl specific python-config
thanks iGentoo for the patch Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=565546 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild b/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
index 5e48466b20b2..56dc96522583 100644
--- a/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
@@ -41,6 +41,9 @@ src_prepare() {
src_configure() {
configuring() {
+ local PYTHON_CONFIG
+ python_export PYTHON_CONFIG
+
# epydoc is python2-only, bug #447642
local apidocs=--disable-api-docs
[[ ${EPYTHON/.*} = "python2" ]] && apidocs=$(use_enable doc api-docs)
@@ -49,7 +52,8 @@ src_configure() {
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--disable-html-docs \
${apidocs} \
- PYTHON_LIBS="$(python-config --ldflags)"
+ PYTHON_INCLUDES="$(${PYTHON_CONFIG} --includes)" \
+ PYTHON_LIBS="$(${PYTHON_CONFIG} --ldflags)"
# configure assumes that ${PYTHON}-config executable exists :/
}
python_foreach_impl run_in_build_dir configuring