summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild b/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
index 5e48466b20b2..56dc96522583 100644
--- a/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
@@ -41,6 +41,9 @@ src_prepare() {
src_configure() {
configuring() {
+ local PYTHON_CONFIG
+ python_export PYTHON_CONFIG
+
# epydoc is python2-only, bug #447642
local apidocs=--disable-api-docs
[[ ${EPYTHON/.*} = "python2" ]] && apidocs=$(use_enable doc api-docs)
@@ -49,7 +52,8 @@ src_configure() {
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--disable-html-docs \
${apidocs} \
- PYTHON_LIBS="$(python-config --ldflags)"
+ PYTHON_INCLUDES="$(${PYTHON_CONFIG} --includes)" \
+ PYTHON_LIBS="$(${PYTHON_CONFIG} --ldflags)"
# configure assumes that ${PYTHON}-config executable exists :/
}
python_foreach_impl run_in_build_dir configuring