summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-otp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest2
-rw-r--r--dev-python/django-otp/django-otp-0.2.7.ebuild23
-rw-r--r--dev-python/django-otp/django-otp-0.3.1.ebuild23
-rw-r--r--dev-python/django-otp/metadata.xml12
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
new file mode 100644
index 000000000000..762813281b03
--- /dev/null
+++ b/dev-python/django-otp/Manifest
@@ -0,0 +1,2 @@
+DIST django-otp-0.2.7.tar.gz 76879 SHA256 dfc305aa894da2b7111c8846d90254b0d9099f415e14165f6e784f5ceddd5f3f SHA512 b48c6dd505ed06b4028a1d27213ea759a1a54ca5f4e5c8dc2aad826535a80295fcdde3a1da455256927d26906e53ee40c47a0ab89de5c6331c2f3567e43fdae7 WHIRLPOOL eb819e389d924953537f0f9db2dff56631b07ea50f898abd398f873dad0144255e14984f6f5aa2ab0d0bd296163c995c7837ab6fafefab87646189047b839f52
+DIST django-otp-0.3.1.tar.gz 38800 SHA256 2aa9f24d655ca0c2583b7fc08c603c2861f337155e35fcc5aae9946e6985db45 SHA512 6eb78da109609ab843d97c170615a2273f32fa02cd9ca874f8e059c80736d98015477c1c15e8db2fba59a449b44c471f067e3ddb87776378e908c04e3a8a82db WHIRLPOOL fe27c2fbdd89ff279694d4b2baa0cd11354c104baccbad8282036ddd476da5b3cadb331d372c7114bcc77f885c606f875039e27b72f1d271fa1df7387e794d2a
diff --git a/dev-python/django-otp/django-otp-0.2.7.ebuild b/dev-python/django-otp/django-otp-0.2.7.ebuild
new file mode 100644
index 000000000000..407eec6f7e92
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable framework for adding two-factor authentication to Django using one-time passwords"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/django-1.4.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-otp/django-otp-0.3.1.ebuild b/dev-python/django-otp/django-otp-0.3.1.ebuild
new file mode 100644
index 000000000000..407eec6f7e92
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable framework for adding two-factor authentication to Django using one-time passwords"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/django-1.4.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-otp/metadata.xml b/dev-python/django-otp/metadata.xml
new file mode 100644
index 000000000000..c3c00c114afe
--- /dev/null
+++ b/dev-python/django-otp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz (ercpe)</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-otp</remote-id>
+ <remote-id type="bitbucket">psagers/django-otp</remote-id>
+ </upstream>
+</pkgmetadata>