summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest2
-rw-r--r--dev-python/django-otp/django-otp-0.2.7.ebuild23
-rw-r--r--dev-python/django-otp/django-otp-0.3.1.ebuild23
-rw-r--r--dev-python/django-otp/metadata.xml12
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
new file mode 100644
index 000000000000..762813281b03
--- /dev/null
+++ b/dev-python/django-otp/Manifest
@@ -0,0 +1,2 @@
+DIST django-otp-0.2.7.tar.gz 76879 SHA256 dfc305aa894da2b7111c8846d90254b0d9099f415e14165f6e784f5ceddd5f3f SHA512 b48c6dd505ed06b4028a1d27213ea759a1a54ca5f4e5c8dc2aad826535a80295fcdde3a1da455256927d26906e53ee40c47a0ab89de5c6331c2f3567e43fdae7 WHIRLPOOL eb819e389d924953537f0f9db2dff56631b07ea50f898abd398f873dad0144255e14984f6f5aa2ab0d0bd296163c995c7837ab6fafefab87646189047b839f52
+DIST django-otp-0.3.1.tar.gz 38800 SHA256 2aa9f24d655ca0c2583b7fc08c603c2861f337155e35fcc5aae9946e6985db45 SHA512 6eb78da109609ab843d97c170615a2273f32fa02cd9ca874f8e059c80736d98015477c1c15e8db2fba59a449b44c471f067e3ddb87776378e908c04e3a8a82db WHIRLPOOL fe27c2fbdd89ff279694d4b2baa0cd11354c104baccbad8282036ddd476da5b3cadb331d372c7114bcc77f885c606f875039e27b72f1d271fa1df7387e794d2a
diff --git a/dev-python/django-otp/django-otp-0.2.7.ebuild b/dev-python/django-otp/django-otp-0.2.7.ebuild
new file mode 100644
index 000000000000..407eec6f7e92
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable framework for adding two-factor authentication to Django using one-time passwords"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/django-1.4.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-otp/django-otp-0.3.1.ebuild b/dev-python/django-otp/django-otp-0.3.1.ebuild
new file mode 100644
index 000000000000..407eec6f7e92
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable framework for adding two-factor authentication to Django using one-time passwords"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/django-1.4.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/django-otp/metadata.xml b/dev-python/django-otp/metadata.xml
new file mode 100644
index 000000000000..c3c00c114afe
--- /dev/null
+++ b/dev-python/django-otp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz (ercpe)</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-otp</remote-id>
+ <remote-id type="bitbucket">psagers/django-otp</remote-id>
+ </upstream>
+</pkgmetadata>