summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-12 09:51:26 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-12 10:02:00 +0200
commit9a363583773c85e78cc9cd3353932f3254efedd3 (patch)
treea3072d84d430c0b81c6e5243732b48fb2053209e /dev-python/fastimport
parentmedia-libs/rubberband: some fixes in 1.9.1-r1 (diff)
downloadgentoo-9a363583773c85e78cc9cd3353932f3254efedd3.tar.gz
gentoo-9a363583773c85e78cc9cd3353932f3254efedd3.tar.bz2
gentoo-9a363583773c85e78cc9cd3353932f3254efedd3.zip
dev-python/fastimport: Bump to 0.9.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastimport')
-rw-r--r--dev-python/fastimport/Manifest1
-rw-r--r--dev-python/fastimport/fastimport-0.9.11.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/fastimport/Manifest b/dev-python/fastimport/Manifest
index 534030885de1..f487a4382aff 100644
--- a/dev-python/fastimport/Manifest
+++ b/dev-python/fastimport/Manifest
@@ -1,2 +1,3 @@
+DIST fastimport-0.9.11.tar.gz 41764 BLAKE2B afb82878ea1996894ff71fe99edc5ca26d45f98eedf7a8a6e85af45949e1e81c2112de9fc2c026438306a8a0e89c484063954ba7d2ff9a80c6b71ab40174f8d4 SHA512 e1b7e4897542ef6f33af51e1018340a6807688e44424e4e7e482b3347264d58d4290678cc2cfa230af500a53cabdcf35c9e7b03c8ff0f1ec3e6e0a9e869a1455
DIST fastimport-0.9.8.tar.gz 39512 BLAKE2B 484ba865e749cca33df73417285e51a9117e7c905ab2922588d6eef9a64ea6b3d72de285a2affbe7d4a770ead9ece30f6242777087af1c469d59c8f2a4e1b008 SHA512 5d195b641cf6138fdbc6c75781a4a6d3699e3ada9743bbe4c4264879b2da2f8a2e995e7cc3955a5241e9c7a7f24f8114474a0a30907f86e2e335e2be4669f588
DIST fastimport-0.9.9.tar.gz 41690 BLAKE2B c07774916d42a6ad98fea3fa8185bd6fd4e2b908d7eb90ec28a2d7dbe5fd806a97075ba0bb5e6dc4fa3330c9e1e46db125daa11062dba52cc9ebc4486c0fff12 SHA512 15005da2056e0d489f9317138833131ae2067cc5b4acd1ab8e82142c6a71e7cc600c3d5a2cbfc151ca253ba3f6aa5f0328fb45dfa912987bb28d4762248298b8
diff --git a/dev-python/fastimport/fastimport-0.9.11.ebuild b/dev-python/fastimport/fastimport-0.9.11.ebuild
new file mode 100644
index 000000000000..a000b6debba9
--- /dev/null
+++ b/dev-python/fastimport/fastimport-0.9.11.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://github.com/jelmer/python-fastimport"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite ||
+ die "Tests fail with ${EPYTHON}"
+}