summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/fexpect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/fexpect')
-rw-r--r--dev-python/fexpect/Manifest1
-rw-r--r--dev-python/fexpect/fexpect-0.2.ebuild31
-rw-r--r--dev-python/fexpect/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/fexpect/Manifest b/dev-python/fexpect/Manifest
new file mode 100644
index 000000000000..1c7698ca081b
--- /dev/null
+++ b/dev-python/fexpect/Manifest
@@ -0,0 +1 @@
+DIST fexpect-0.2.tar.gz 6260 SHA256 d037d1282a43ed38b3edc6b33dabaa543b8b274e92753cbb565d21aa10f52a0c SHA512 45b14bfc50f5e2a5dca45594b024a213c270196a89b1ee51c6a8107d6f8b46ab1ca1362331372492307a2e42adef60be444465d33248788ae2ba2728e42cf580 WHIRLPOOL 2dfd4092ab30870c36ad2dedcaaeff65e58bd1530f3a71831c2ad41d4f4dbdb484c8f79a6baffc585dc48e855ddd9e8c08a3f1c8993628c689907dc3c79bf174
diff --git a/dev-python/fexpect/fexpect-0.2.ebuild b/dev-python/fexpect/fexpect-0.2.ebuild
new file mode 100644
index 000000000000..de6a48b575a2
--- /dev/null
+++ b/dev-python/fexpect/fexpect-0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension for fabric to handle prompts through pexpect"
+HOMEPAGE="https://github.com/ilogue/fexpect"
+SRC_URI="https://github.com/ilogue/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/fabric[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/shortuuid[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/fexpect/metadata.xml b/dev-python/fexpect/metadata.xml
new file mode 100644
index 000000000000..2ab56b42c053
--- /dev/null
+++ b/dev-python/fexpect/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ilogue/fexpect</remote-id>
+ </upstream>
+</pkgmetadata>