summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-23 01:21:51 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-23 01:33:46 +0100
commit8a4eda9f6f20d497517dad0f0c45f4f0ae8dae8c (patch)
tree71d61951dfca1ab290b9570aa5d304d55c2c9464 /dev-python/flask
parentdev-python/flask: Fix MissingTestRestrict (diff)
downloadgentoo-8a4eda9f6f20d497517dad0f0c45f4f0ae8dae8c.tar.gz
gentoo-8a4eda9f6f20d497517dad0f0c45f4f0ae8dae8c.tar.bz2
gentoo-8a4eda9f6f20d497517dad0f0c45f4f0ae8dae8c.zip
dev-python/flask: Prepare for 3.8, fix tests
Update the ebuild to be 3.8-ready. However, don't add 3.8 yet as it fails one test. Need to investigate or look for a patch. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/flask-1.1.1.ebuild9
-rw-r--r--dev-python/flask/flask-9999.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/flask/flask-1.1.1.ebuild b/dev-python/flask/flask-1.1.1.ebuild
index 309a5494f244..6c634728d160 100644
--- a/dev-python/flask/flask-1.1.1.ebuild
+++ b/dev-python/flask/flask-1.1.1.ebuild
@@ -32,9 +32,14 @@ RDEPEND="dev-python/click[${PYTHON_USEDEP}]
>=dev-python/werkzeug-0.15[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+python_check_deps() {
+ use doc || return 0
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
python_prepare_all() {
# Prevent un-needed d'loading
sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
@@ -47,7 +52,7 @@ python_compile_all() {
python_test() {
PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
- py.test -v || die "Testing failed with ${EPYTHON}"
+ pytest -vv -p no:httpbin || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
index 309a5494f244..6c634728d160 100644
--- a/dev-python/flask/flask-9999.ebuild
+++ b/dev-python/flask/flask-9999.ebuild
@@ -32,9 +32,14 @@ RDEPEND="dev-python/click[${PYTHON_USEDEP}]
>=dev-python/werkzeug-0.15[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+python_check_deps() {
+ use doc || return 0
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+}
+
python_prepare_all() {
# Prevent un-needed d'loading
sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
@@ -47,7 +52,7 @@ python_compile_all() {
python_test() {
PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
- py.test -v || die "Testing failed with ${EPYTHON}"
+ pytest -vv -p no:httpbin || die "Testing failed with ${EPYTHON}"
}
python_install_all() {