summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-09-30 15:53:13 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-10-07 11:11:10 -0700
commit74bbfed18d48ae0f067e3048baa9ff4fc8ae5285 (patch)
tree3e9394b09b1f4b7ad5351b5f4999701748ce4695 /dev-python/hpack
parentdev-db/slony1: Version Bump (diff)
downloadgentoo-74bbfed18d48ae0f067e3048baa9ff4fc8ae5285.tar.gz
gentoo-74bbfed18d48ae0f067e3048baa9ff4fc8ae5285.tar.bz2
gentoo-74bbfed18d48ae0f067e3048baa9ff4fc8ae5285.zip
dev-python/hpack: New package, dependency for dev-python/hyper-h2
Also an indirect dependency of dev-python/twisted Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/Manifest1
-rw-r--r--dev-python/hpack/hpack-2.3.0.ebuild52
-rw-r--r--dev-python/hpack/metadata.xml24
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/hpack/Manifest b/dev-python/hpack/Manifest
new file mode 100644
index 000000000000..a74bd98c2af1
--- /dev/null
+++ b/dev-python/hpack/Manifest
@@ -0,0 +1 @@
+DIST hpack-2.3.0.tar.gz 41610 SHA256 51bd9aa8151efd190d70fe87991b1e3b79be0f93f0e34088fba2a8d34877a0a9 SHA512 a3d13da105482bb258ee3a2314b2629215028777f84127f71359f08819c96af088a3952bb0a74435472035d10ee6e3943cdad689a28f04cbc12cddcc4af9a8a7 WHIRLPOOL 8f47b6c2a78f915b009c35ecefa517486c27eb45f0b99834718152e14f9e934c23d52981c87b0c39af28fb9cb58d94e5eda07db2e999c37900b76b7aefd64b08
diff --git a/dev-python/hpack/hpack-2.3.0.ebuild b/dev-python/hpack/hpack-2.3.0.ebuild
new file mode 100644
index 000000000000..7bd359160a6d
--- /dev/null
+++ b/dev-python/hpack/hpack-2.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="http://python-hyper.org/hpack https://pypi.python.org/pypi/hpack"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove a test that is not part of the mainstream tests
+ # Also, it's data directory is not included in the release
+ rm test/test_hpack_integration.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all(){
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v hpack test/|| die
+ cd test
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/hpack/metadata.xml b/dev-python/hpack/metadata.xml
new file mode 100644
index 000000000000..e0b56ef6d725
--- /dev/null
+++ b/dev-python/hpack/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dol-sen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>cory@lukasa.co.uk</email>
+ <name>Cory Benfield</name>
+ </maintainer>
+ <remote-id type="pypi">hpack</remote-id>
+ </upstream>
+ <longdescription>This module contains a pure-Python HTTP/2 header encoding
+ (HPACK) logic for use in Python programs that implement HTTP/2. It
+ also contains a compatibility layer that automatically enables the use
+ of nghttp2 if it’s available.
+ </longdescription>
+</pkgmetadata>