summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-06-09 09:45:32 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-06-09 11:18:45 -0700
commite1dc42245d39d635175f5ae42c234eed7f4a21a9 (patch)
treebb7d1fd7e887fd2ad7ffc69581f43215c8c35d58 /dev-python/hpack
parentdev-python/hyper-h2: Version bumps for 2.x, 3.x series (diff)
downloadgentoo-e1dc42245d39d635175f5ae42c234eed7f4a21a9.tar.gz
gentoo-e1dc42245d39d635175f5ae42c234eed7f4a21a9.tar.bz2
gentoo-e1dc42245d39d635175f5ae42c234eed7f4a21a9.zip
dev-python/hpack: Version bump
Update HOMEPAGE Package-Manager: Portage-2.3.6_p2, Repoman-2.3.2_p70
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/Manifest1
-rw-r--r--dev-python/hpack/hpack-2.3.0-r1.ebuild2
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild39
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/hpack/Manifest b/dev-python/hpack/Manifest
index a74bd98c2af1..21c7ef9c83f9 100644
--- a/dev-python/hpack/Manifest
+++ b/dev-python/hpack/Manifest
@@ -1 +1,2 @@
DIST hpack-2.3.0.tar.gz 41610 SHA256 51bd9aa8151efd190d70fe87991b1e3b79be0f93f0e34088fba2a8d34877a0a9 SHA512 a3d13da105482bb258ee3a2314b2629215028777f84127f71359f08819c96af088a3952bb0a74435472035d10ee6e3943cdad689a28f04cbc12cddcc4af9a8a7 WHIRLPOOL 8f47b6c2a78f915b009c35ecefa517486c27eb45f0b99834718152e14f9e934c23d52981c87b0c39af28fb9cb58d94e5eda07db2e999c37900b76b7aefd64b08
+DIST hpack-3.0.0.tar.gz 5305971 SHA256 0f8f5f92cfa59f91804eabb237d4b18895f3e200e282c41cedf6cd11a4416daa SHA512 7b9cf5e643dff2a6454bfe419b797c8ed1a0fe6ec3b725d2696da5a820ab96fe87a64e600b1831c7024bd82616b155a0aa058301acb32172155b6538ba0a73c6 WHIRLPOOL 3252253a9f489d5bf4bc8ef243f576c99f5fa9a49d2767ca1e7f59ba15da1e00de3b083e6e64f69bb8c3c32bf27b177aaaad94b3cf1aba1c726d473d7b062403
diff --git a/dev-python/hpack/hpack-2.3.0-r1.ebuild b/dev-python/hpack/hpack-2.3.0-r1.ebuild
index c668992919bb..d4a79cf5156a 100644
--- a/dev-python/hpack/hpack-2.3.0-r1.ebuild
+++ b/dev-python/hpack/hpack-2.3.0-r1.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
inherit distutils-r1
DESCRIPTION="Pure-Python HPACK header compression"
-HOMEPAGE="http://python-hyper.org/hpack https://pypi.python.org/pypi/hpack"
+HOMEPAGE="https://python-hyper.org/hpack/en/latest/ https://pypi.python.org/pypi/hpack"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
new file mode 100644
index 000000000000..67d5b0266c6a
--- /dev/null
+++ b/dev-python/hpack/hpack-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="https://python-hyper.org/hpack/en/latest/ https://pypi.python.org/pypi/hpack"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Remove a test that is not part of the mainstream tests
+ # Also, it's data directory is not included in the release
+ rm test/test_hpack_integration.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v hpack test/|| die
+ cd test
+}