summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-12 06:44:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-12 07:21:41 +0200
commit91f4d3794e7c5fb638a24bda40b415c9236640cf (patch)
tree6a5939b7c8fa51239974811104784de4e1b2362e /dev-python/jaraco-collections
parentdev-python/jaraco-collections: Remove pypy3 for the time being (diff)
downloadgentoo-91f4d3794e7c5fb638a24bda40b415c9236640cf.tar.gz
gentoo-91f4d3794e7c5fb638a24bda40b415c9236640cf.tar.bz2
gentoo-91f4d3794e7c5fb638a24bda40b415c9236640cf.zip
dev-python/jaraco-collections: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index b55e5f8350be..ebd90b36f1c5 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1 +1,2 @@
DIST jaraco.collections-3.3.0.tar.gz 18563 BLAKE2B 80e8463324598cdd6025984c6ab304b108521a606de87fa7aeacbb2234aec5fce20319d7cd288caa5a46b1fefb7e7686a2d00e668e90c38b943082267e6b4ceb SHA512 23fea645226bcfbd5f034877aff7846960ad99d65d451bdbf5b8abb166356074d07780ea8e2e25d31fd03343929596dcd64a9ec949c1ff056c11862e043a8b7e
+DIST jaraco.collections-3.4.0.tar.gz 14887 BLAKE2B 2c1e87b18dc3ca68fb5b849b30cc0284b8a8daed9b6b2b075a753f7ccf91feb487734a38bb7fc88d29020b0b1980346109551a8bba5d0b3a7f4a491c0dcb1615 SHA512 8e427f98dbcfad3f9042d1f080b2bf8012fdaaf084e230f9b46ff078623b047c2d9dab41ed0303df5dd070abce2a25289281113a97e8ab8d819048d30b8d314a
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild
new file mode 100644
index 000000000000..477206eaacea
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest