summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:34:03 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:34:03 +0100
commit2f7eb7d37f64648786f2d98263a4086bc385189e (patch)
tree867b9d9cc35d8db3d2bec031ed57aa2997e9165b /dev-python/jupyter
parentdev-python/notebook: Import from science overlay (diff)
downloadgentoo-2f7eb7d37f64648786f2d98263a4086bc385189e.tar.gz
gentoo-2f7eb7d37f64648786f2d98263a4086bc385189e.tar.bz2
gentoo-2f7eb7d37f64648786f2d98263a4086bc385189e.zip
dev-python/jupyter: Import from science overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/jupyter')
-rw-r--r--dev-python/jupyter/Manifest1
-rw-r--r--dev-python/jupyter/jupyter-1.0.0.ebuild45
-rw-r--r--dev-python/jupyter/metadata.xml12
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jupyter/Manifest b/dev-python/jupyter/Manifest
new file mode 100644
index 000000000000..4ba519e9300d
--- /dev/null
+++ b/dev-python/jupyter/Manifest
@@ -0,0 +1 @@
+DIST jupyter-1.0.0.tar.gz 12916 SHA256 d9dc4b3318f310e34c82951ea5d6683f67bed7def4b259fafbfe4f1beb1d8e5f SHA512 1f0bc83f7a127c98ccf4b3868814116aa272ea5d0baac52d7a022305af7e2da28ca2b90fa3554ff085d8df3eb6d8b8cde80bf02b8e66064c59900b926d73c520 WHIRLPOOL c648e494556f6d5d3a42594bb4c2fd5701b2f993cf467d6011f67141de2e80d6cccf1adfcfcda6445d8325604e67d6af4465b6e2d79443de67512a2a29360855
diff --git a/dev-python/jupyter/jupyter-1.0.0.ebuild b/dev-python/jupyter/jupyter-1.0.0.ebuild
new file mode 100644
index 000000000000..7dfd0060b397
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jupyter/metadata.xml b/dev-python/jupyter/metadata.xml
new file mode 100644
index 000000000000..00118fe11137
--- /dev/null
+++ b/dev-python/jupyter/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+Install the Jupyter system, including the notebook, qtconsole, and the IPython kernel.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">jupyter</remote-id>
+ <remote-id type="github">jupyter/jupyter</remote-id>
+ </upstream>
+</pkgmetadata>