summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/libnacl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/libnacl')
-rw-r--r--dev-python/libnacl/Manifest2
-rw-r--r--dev-python/libnacl/libnacl-1.4.0.ebuild23
-rw-r--r--dev-python/libnacl/libnacl-1.4.3.ebuild23
-rw-r--r--dev-python/libnacl/metadata.xml12
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/libnacl/Manifest b/dev-python/libnacl/Manifest
new file mode 100644
index 000000000000..4682a7f693cc
--- /dev/null
+++ b/dev-python/libnacl/Manifest
@@ -0,0 +1,2 @@
+DIST libnacl-1.4.0.tar.gz 28233 SHA256 fee644e684472b307e864db0d01d81915e7fc2c9fd4a64c15a35e4883102d7d5 SHA512 5f28ae4f0a2dc482ad5ea9a87431dc0fee42664a77a69ee3328265225c2e0d736869d7a9e3927f530ca00148be36d32ffb72fafe4471302c71ea7e0ff7534643 WHIRLPOOL 89ffc84ec52e676434477fe25d6133a8d4b8c7d0ecf4096ddab585f9150f506ccc4c3802ac477307ad4c6e42ae4d8ba4b4fc8ae45cabd8b5f7aac2cdfcb75349
+DIST libnacl-1.4.3.tar.gz 28777 SHA256 873614913c90c4011f791a8fd1448f6bb3ab7dc8cdd329d1baaa65e7e1d1a929 SHA512 92b7d5e8856e69404e8d5b9eee9f87374a4ba251b040c00f78b4c9e8094f5306241be0632c82f7c4edd88a9dd654cdd6323674a7789392d87064bd86cfbe66f2 WHIRLPOOL b5561c233f8cf0dc4f2b979c86b9a5bb76c49a730399ee6bfc5946150523057228f1503fefed728675c5286da3afaad7649d2956d832f866576e0820d893d217
diff --git a/dev-python/libnacl/libnacl-1.4.0.ebuild b/dev-python/libnacl/libnacl-1.4.0.ebuild
new file mode 100644
index 000000000000..4e2a2ec0e7ea
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="https://libnacl.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/libsodium"
+
+python_test() {
+ ${EPYTHON} tests/runtests.py || die
+}
diff --git a/dev-python/libnacl/libnacl-1.4.3.ebuild b/dev-python/libnacl/libnacl-1.4.3.ebuild
new file mode 100644
index 000000000000..b04448e38ccc
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.4.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="https://libnacl.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/libsodium"
+
+python_test() {
+ ${EPYTHON} tests/runtests.py || die
+}
diff --git a/dev-python/libnacl/metadata.xml b/dev-python/libnacl/metadata.xml
new file mode 100644
index 000000000000..91d2d7777dba
--- /dev/null
+++ b/dev-python/libnacl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">libnacl</remote-id>
+ </upstream>
+</pkgmetadata>