summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:33:24 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commited8a5d922bed4df6ef52ae353832c97bcbed1432 (patch)
treeb8e59b4463dbe46f1d5def35a306f4bb7d6686c9 /dev-python/ptyprocess
parentdev-python/progress: Add python3.5 support (diff)
downloadgentoo-ed8a5d922bed4df6ef52ae353832c97bcbed1432.tar.gz
gentoo-ed8a5d922bed4df6ef52ae353832c97bcbed1432.tar.bz2
gentoo-ed8a5d922bed4df6ef52ae353832c97bcbed1432.zip
dev-python/ptyprocess: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ptyprocess')
-rw-r--r--dev-python/ptyprocess/ptyprocess-0.5-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ptyprocess/ptyprocess-0.5-r1.ebuild b/dev-python/ptyprocess/ptyprocess-0.5-r1.ebuild
new file mode 100644
index 000000000000..1c1b3c9f50c6
--- /dev/null
+++ b/dev-python/ptyprocess/ptyprocess-0.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Run a subprocess in a pseudo terminal"
+HOMEPAGE="https://github.com/pexpect/ptyprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test --verbose --verbose || die
+}